Support » Plugin: WooCommerce » Products disappeared after upgrading to 2.6

  • Resolved Víctor Enrich

    (@victorenrich)


    Good afternoon.
    I’ve upgraded Woocommerce and then run the updater, getting the message that database may not be updated and getting updated in the background.
    However, once the database ver 2.6 is updated as seen on the system status I see that all my products have disappeared from the front-end, in both shop pages and single product pages.
    I’ve followed some instructions found in other similar posts but nothing has worked for me so I’ve been forced to restore a 24h ago backup and recover my 2.5.5- version.
    How can this thing get fixed?
    Thanks for your support.

    https://wordpress.org/plugins/woocommerce/

Viewing 13 replies - 1 through 13 (of 13 total)
  • Since I haven’t performed other actions, such as adding to cart or checking out, I can’t assure that there may not be other errors, as O’ve noticed that other users have.

    Plugin Author Mike Jolley

    (@mikejolley)

    This will help you run the updater https://wordpress.org/support/topic/26-update-database-update-not-completing-missing-category-images?replies=1

    Regarding products, nothing during upgrade deletes products. Are they visible in the backend?

    When you updated, please don’t say you uninstalled first?

    Thanks for answering Mike.
    No, I didn’t uninstall.
    The products are displayed properly in the backend, everything looks normal, but when clicking on the url’s they send me to “non found” pages, it’s very weird. ALso no products show in shop, categoray, tags etc pages.
    I’ve already tried what you suggest but I don’t find the event in the list so I am unable to run it.
    I can give you admin credentials so you can take a look if you wish.
    Thanks

    Caleb Burks

    (@icaleb)

    Automattic Happiness Engineer

    Hmm, couple of thoughts / things to try:

    – Re-save your permalinks at Settings > Permalinks.
    – Try re-saving a product and then viewing it.
    – Try editing a products url then viewing it.
    – Make sure the product isn’t set to hidden.
    – Try creating a new product and see if it works.

    Permalinks resaved and nothing happens
    Products created and nothing happens
    Products are not hidden…

    Very very strange

    Plugin Author Mike Jolley

    (@mikejolley)

    Thanks.
    Regarding plugins and themes, I’ve tested the update in another installation and same problem happens, products disappear.
    In both installations I’ve activated Twenty Fifteen theme and same again, no products.
    My server’s Php version is 5.6
    I’d love to give you admin credentials in order to make you see the situation, otherwise if there’s no solution the only thing I see here is doing a clean install, with 2.6 installed at the very beginning

    Plugin Author Mike Jolley

    (@mikejolley)

    I can look if you DM me a login on twitter. @mikejolley

    Sent! 🙂
    You will find the 2.5.5 version installed, since I restored it from yesterday.

    Plugin Author Mike Jolley

    (@mikejolley)

    Narrowed down to catalog visibility plugin.

    hi did we find a fix to this because i have just done the same and no products are displaying on my site now. ive even tried to role the update back to the previous version and it is still doing the same thing.

    please can someone help?

    Plugin Author Mike Jolley

    (@mikejolley)

    kevblucas in this thread it was caused by catalog visibility plugin.

    kevblucas

    (@kevblucas)

    thank you ill take a look.

Viewing 13 replies - 1 through 13 (of 13 total)
  • The topic ‘Products disappeared after upgrading to 2.6’ is closed to new replies.