Support » Plugin: FG Magento to WooCommerce » Products accounted for, no errors but also no import

  • Resolved lamberbee

    (@lamberbee)


    Hello,

    I have a local setup, WP 4.8,Woocommerce 3.0.8 and the FG Magento to WC Importer 2.28.0
    Also have the Magento DB V1.9.0.1 loaded on my local MySQL DB, Connection test works fine, no issues.

    First attempt gave a lot of errors. The images were not imported. Also got this corrected by using the URL config parameter. The log shows:

    === START import 2017-06-19 20:47:50 ===
    Connected with success to the Magento database
    Magento data found:
    3 CMS pages
    588 product categories
    752 products
    
    [WARNING] Your Magento database contains several customers. You need the Premium version to import them.
    [WARNING] Your Magento database contains customer groups. You need the Premium version and the Customer Groups add-on to import them.
    Importing articles...
    0 articles imported
    Importing product categories...
    0 product categories imported
    Importing products...
    0 products imported
    0 medias imported
    IMPORT COMPLETED
    === END import 2017-06-19 20:47:50 ===

    Also enabled the WP_DEBUG but nothing logged.
    Not sure where to look why nothing is imported. Any idea’s please?

    Thanks,
    lamberbee

Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Author Kerfred

    (@kerfred)

    To import the images, you must fill in the URL field with the URL of the original Magento site.

    To restart the import from scratch, you must remove properly the imported data with the button “Empty WordPress content”.

    Thanks for the fast reply Kerfred. It was a fresh WP install with Woocommerce. I already did some additional tests, using the ‘Empty WordPress Button’, removing all data and WP Content.

    The URL field is http://lemit.dev/magento. I just put all data-files in that folder. And that gave some progress. All 829 medias were imported from the Magento DB into WP Media. But sadly no products imported.
    Only 10 errors I got were these:

    [ERROR] Can't copy http://lemit.dev/magento/media/catalog/product/a/n/antidiefstal_bouten_15_-_2_1.jpg to /Users/lamberbee/Documents/Websites/lemit.dev/wp-content/uploads/2013/11/antidiefstal_bouten_15_-_2_1.jpg : Service Unavailable

    Service unavailable? No idea why it doesn’t work for these jpg’s.

    Plugin Author Kerfred

    (@kerfred)

    It may be because of the URL http://lemit.dev which is a local address.
    This post may help you: https://www.lifewire.com/g00/503-service-unavailable-explained-2622940?i10c.referrer=https%3A%2F%2Fwww.google.fr%2F

    If you have previously deleted the imported products manually, you need to remove them properly with the button “Empty WordPress content” in order to import them again.

    lamberbee

    (@lamberbee)

    Not sure how this link about the 503 issue can help, or even if it is related. And yes, I used the button to remove the imported products. The Woocommerce is empty and even after the import, there are no products. Only media is imported.

    Plugin Author Kerfred

    (@kerfred)

    Could you open a ticket on https://www.fredericgilles.net/support/ and send us a screenshot of your settings?

    Hello Frederic,

    My potential customer gave me an old back-up, which was Magento. Now it seems the webshop is Prestashop. So thanks for your response. But I will not pursue this specific conversion anymore.

    Thank you,
    Lamberbee

    Plugin Author Kerfred

    (@kerfred)

    Thanks for your feedback.
    For PrestaShop, you can use https://wordpress.org/plugins/fg-prestashop-to-woocommerce/

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Products accounted for, no errors but also no import’ is closed to new replies.