Support » Plugins and Hacks » [Resolved] Product won't appear in shop [2.1 Update]

[Resolved] Product won't appear in shop [2.1 Update]

  • Hello,
    After the last WooCommerce update, whenever I add something new to my shop it won’t show up on Shop page.
    If I use direct link to product I can see it, but inside shop I can’t.

    Anyone have fix for this?
    I tried with saving permalinks again, clearing website cache, doing almost everything I can remember, but still no fix.

    A some kind of help would be highly appreciated.



Viewing 5 replies - 1 through 5 (of 5 total)
  • This sounds like an issue that happens when themes bundle outdated WooCommerce template files. Please temporarily switch to a default theme like Twenty Twelve and see if that resolves this issue.

    Thank you for respond, but that didn’t fix my problem. I see a lot of users complaining about that bug.
    I use Mystile and it’s fully updated, switched to TT and problem still persist.

    I found a way for this. From 2.1 you MUST use SKU field when creating product. I had that disabled on previous versions.

    Mark this as solved!

    No, this wasn’t completely related to the SKU field but might have been a workaround that actually fixed it for you. Version 2.1.1 is now available and that includes the official fix for this issue. Sorry for any inconvenience.

    2.1.1 wasn’t a fix for this, I tried. Since I used SKU field, it finally appear in my Shop page 🙂

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘[Resolved] Product won't appear in shop [2.1 Update]’ is closed to new replies.