Support » Plugins and Hacks » [Resolved] Product Variations doesnst work

[Resolved] Product Variations doesnst work

Viewing 15 replies - 1 through 15 (of 20 total)
  • What version of WooCommerce are you using?

    Do you get Javascript errors in your browsers console?

    Please give me steps to reproduce, for example what kind of attribute you’ve added to the product before trying to add variations.

    Hy Coen,

    No i dont get Java Errors.

    I tried with different attributes…

    i have a IT Webshop as you can see on somion.at

    Mostly i add Storage variations, CPU things like that.

    And everything worked fine.. but since i did the latest update of woocommerce it doesnst work any more…

    i also tried to delete and install the old version but nothing happened.

    thanks for your help

    In order for me to properly give you support, can you please answer all my questions?

    I need to know the version of WooCommerce that you are using, as well as a step by step description of how to reproduce your issue.

    I’ve made a Screencapture for you wich should describe everything.

    thanks a lot.


    Hello guys

    I can confirm that I have exactly the same problem.

    WC: 2.0.7
    Woo Sliding 1.5.5.
    WP: 3.5.1


    did you find a solution already peyote?


    When you click one of the buttons, that are not responding, do you get any errors in the browsers console? Possibly a Javascript conflict. What plugins are you using?

    Can you please link to the report you can generate on WooCommerce > System Status (do not post it here, but link to it on a site like http://pastebin.com/ please)?

    Also, do those buttons work after you’ve saved the product and then try to add variations, instead of doing it all in one run (just for debugging purposes)?

    √ no i dont get any errors.. simply nothing happens

    √ i just realized if i want to download the system report also nothing happens..

    √ when i save the product first also nothing happens

    Hi Thomas,

    Gerhard at WooThemes helped me sort this one. I dont know if this could be your problem too, but I had a “:” in my attribute tag, which was causing the issue. I.E Select Colour:

    Removing the : from the tag solved my issue.

    Sorry. But that didnt help me.

    Still The Same Problem!!!

    Do you have any other special characters in your attribute names which may break? We’ve been working on making this more robust in the latest release, so when you resave the attribute names it should resolve itself.

    Can you give an example of the attribute names that cause these issues?

    you can the those infos in the youtube video above.

    tried it with many things.. in the latest case simply with yes | no.



    What happens if you save the product first (the big blue Update or Publish button) and then try to use the button that doesn’t work in your video?

    Have you tried ruling out any conflicts with plugins, themes and translations? Have you disabled those and checked if the issue is still there? If so, start enabling everything one by one again, test after activating each and see if that’s the cause of your problem.

    Hy Coen,

    tried to save first.. same problem.

    I also tried to deactive different plugins… it must be a woocommerce plugin problem.. because it came 100% with the update of the plugin itsself… something went wrong there..

    It really sounds like a Javascript error in your site, caused by a conflict. Have you tried disabling all plugins and activating a default theme like Twenty Twelve?

    Please make a screencast that confirms this (let us see that WooCommerce is the only plugin active and the theme is Twenty Twelve. I can’t reproduce it on my end with this configuration. Also check your browsers console for possible errors in the screencast, maybe there is something else we can see there.

Viewing 15 replies - 1 through 15 (of 20 total)
  • The topic ‘[Resolved] Product Variations doesnst work’ is closed to new replies.