Support » Plugin: WooCommerce Stripe Subscription Payment Gateway » Product shows No Such Plan ID when adding a Plan ID into Product Subscription

  • Resolved jchambo

    (@jchambo)


    Not sure why but when I enter the Plan ID from my Stripe Subscriptions list into a product’s Subscription > Stripe Plan ID field, it always returns “No Such Plan.”

    Why?

Viewing 10 replies - 1 through 10 (of 10 total)
  • Plugin Author wsspg

    (@wsspg)

    Hello jchambo,

    Sorry to hear you’re having trouble with Wsspg, let’s see if we can get it to work for you.

    Are you seeing anything regarding this issue in your Stripe logs ?

    Plugin Author wsspg

    (@wsspg)

    No reply; marking the thread as resolved.

    Hello WSSPG !

    I am facing the same trouble after installing your plugin. I created a product, type subscription, filled in the Stripe Pkan ID and got the same message : No Such plan :
    No specific details recorded on Stripe Logs.

    Thx for your help solving this.

    Cheers from Waterloo, Belgium.

    Damien

    Great ! I found out what I mismatched. Live/Test mode w/ Stripe
    You may consider the ticket as closed.

    flemmingha

    (@flemmingha)

    Hi

    I am facing the same issue. I have added both the Stripe live and test API Keys in WP, created a Stripe Plan and found the ID (3), but when I insert it for a product the message is: no such plan: 3.

    There is no mention about the issue in the Stripe logs.

    Any idea what the issue could be?

    Best regards
    Flemming

    Plugin Author wsspg

    (@wsspg)

    Hi flemmingha,

    Are you running Stripe and Wsspg in the same mode (test/live) ?

    jbcommunications

    (@jbcommunications)

    Hi Wsspg team,

    Unfortunately I have the same problem on my site https://www.jb-communications.fr
    I don’t understand because it was working properly for a while, I could add the products with ID without problems but now it doesn’t work.

    Could you help me with this ? If yes please let me know what information you need

    Best regards,

    Jules Bailleul

    Hi,

    I just installed this on a new install. I’m also getting the same issue. I have created plans on both the public and test view in my stripe discount. I’ve added the api keys, enabled the plugin, and have tried live and test option. I still get the error “NO SUCH PLAN” What else can I do? I really need this to work other wise I need to find another plugin.

    Thanks.

    The reason may be the API keys.

    Stripe has keys as follows:
    Live Publishable Key
    Live Secret Key

    Stripe (wsspg) has keys as follows:
    Live Secret Key
    Live Publishable Key

    Summary
    You may have the keys in the wrong location in swwpg

    Solution
    Swap keys

    🙂 Worked for me

    https://internetbreakout.com/muchoblessed

    Same issue for me, no such plan ID. Test settings are right, SSL certificate is installed, keys are correct. Any idea?

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘Product shows No Such Plan ID when adding a Plan ID into Product Subscription’ is closed to new replies.