Support » Plugin: WooCommerce » Product search gives 503 error

  • Resolved yoyoyomar

    (@yoyoyomar)


    Hi

    When making a search query for a product that does not exist, our site returns a ‘503 Service Unavailable’ error every time. And it only happens if you type something that would normally return the ‘no results’ page. If you search for an existing product, the search results page appears as normal.

    Does anyone have any idea as why this is happening? I’ve checked and double checked, and there is nothing wrong with the search box code in the theme.

    Please help!
    Thanks

Viewing 2 replies - 1 through 2 (of 2 total)
  • Plugin Support Thomas Shellberg

    (@shellbeezy)

    Automattic Happiness Engineer

    Hey @yoyoyomar,

    What version of WooCommerce are you running? Is this happening on the front-end of the site or the backend(in WP Admin)? I would test for a conflict:

    1. Temporarily switch your theme to the [Storefront](https://woocommerce.com/products/storefront/) theme.
    2. Try to reproduce the problem: 
    If the problem is resolved, it is a theme conflict. If not, continue to the next step.
    3. Temporarily deactivate all plugins except WooCommerce. You can do this manually or use a plugin to help (see below for tools).
    4. Try to reproduce the problem again. If the problem is resolved, it is a plugin conflict. To figure out which plugin is causing the problem, continue to the next step.
    5. Reactivate your other plugins one by one, testing after each, until you find the one causing conflict

    Plugin Support Melinda

    (@melindahelt)

    Automattic Happiness Engineer

    We haven’t heard back from you in a while, so I’m going to mark this as resolved – if you have any further questions, you can start a new thread.

Viewing 2 replies - 1 through 2 (of 2 total)
  • You must be logged in to reply to this topic.