Support » Plugin: WooCommerce » Product Save Times Out to 502 Error

  • Resolved mikedev

    (@mikedev)


    With the latest version of WordPress and WooCommerce, PHP 7.4, no plugins activated except WooCommerce, using Twenty Twenty theme, I get a 502 error when saving a product or activate/deactivate any plugin.

    On the server we turned off 60 second timeout script, saved a product and save query ran on Apache continually past 15 minutes and never stopped.

    
    ### WordPress Environment ###
    
    WordPress address (URL): https://innerspacedev.wpengine.com
    Site address (URL): https://innerspacedev.wpengine.com
    WC Version: 4.9.1
    REST API Version: ✔ 4.9.1
    WC Blocks Version: ✔ 4.0.0
    Action Scheduler Version: ✔ 3.1.6
    WC Admin Version: ✔ 1.8.3
    Log Directory Writable: ✔
    WP Version: 5.6
    WP Multisite: –
    WP Memory Limit: 512 MB
    WP Debug Mode: –
    WP Cron: ✔
    Language: en_US
    External object cache: –
    
    ### Server Environment ###
    
    Server Info: Apache
    PHP Version: 7.4.13
    PHP Post Max Size: 100 MB
    PHP Time Limit: 3600
    PHP Max Input Vars: 10000
    cURL Version: 7.58.0
    OpenSSL/1.1.1
    
    SUHOSIN Installed: –
    MySQL Version: 5.7.32-35-log
    Max Upload Size: 50 MB
    Default Timezone is UTC: ✔
    fsockopen/cURL: ✔
    SoapClient: ✔
    DOMDocument: ✔
    GZip: ✔
    Multibyte String: ✔
    Remote Post: ✔
    Remote Get: ✔
    
    ### Database ###
    
    WC Database Version: 4.9.1
    WC Database Prefix: wp_
    Total Database Size: 74.71MB
    Database Data Size: 51.71MB
    Database Index Size: 23.00MB
    wp_woocommerce_sessions: Data: 0.00MB + Index: 0.00MB + Engine MyISAM
    wp_woocommerce_api_keys: Data: 0.00MB + Index: 0.00MB + Engine MyISAM
    wp_woocommerce_attribute_taxonomies: Data: 0.00MB + Index: 0.01MB + Engine MyISAM
    wp_woocommerce_downloadable_product_permissions: Data: 0.00MB + Index: 0.00MB + Engine MyISAM
    wp_woocommerce_order_items: Data: 0.01MB + Index: 0.01MB + Engine MyISAM
    wp_woocommerce_order_itemmeta: Data: 0.19MB + Index: 0.07MB + Engine MyISAM
    wp_woocommerce_tax_rates: Data: 0.00MB + Index: 0.00MB + Engine MyISAM
    wp_woocommerce_tax_rate_locations: Data: 0.00MB + Index: 0.00MB + Engine MyISAM
    wp_woocommerce_shipping_zones: Data: 0.00MB + Index: 0.00MB + Engine MyISAM
    wp_woocommerce_shipping_zone_locations: Data: 0.00MB + Index: 0.01MB + Engine MyISAM
    wp_woocommerce_shipping_zone_methods: Data: 0.00MB + Index: 0.00MB + Engine MyISAM
    wp_woocommerce_payment_tokens: Data: 0.00MB + Index: 0.00MB + Engine MyISAM
    wp_woocommerce_payment_tokenmeta: Data: 0.00MB + Index: 0.00MB + Engine MyISAM
    wp_woocommerce_log: Data: 0.00MB + Index: 0.00MB + Engine MyISAM
    wp_actionscheduler_actions: Data: 0.02MB + Index: 0.11MB + Engine InnoDB
    wp_actionscheduler_claims: Data: 0.02MB + Index: 0.02MB + Engine InnoDB
    wp_actionscheduler_groups: Data: 0.02MB + Index: 0.02MB + Engine InnoDB
    wp_actionscheduler_logs: Data: 0.02MB + Index: 0.03MB + Engine InnoDB
    wp_commentmeta: Data: 0.02MB + Index: 0.03MB + Engine InnoDB
    wp_comments: Data: 0.08MB + Index: 0.09MB + Engine InnoDB
    wp_gf_addon_feed: Data: 0.01MB + Index: 0.00MB + Engine MyISAM
    wp_gf_draft_submissions: Data: 0.00MB + Index: 0.00MB + Engine MyISAM
    wp_gf_entry: Data: 1.35MB + Index: 0.15MB + Engine MyISAM
    wp_gf_entry_meta: Data: 5.33MB + Index: 3.02MB + Engine MyISAM
    wp_gf_entry_notes: Data: 0.27MB + Index: 0.08MB + Engine MyISAM
    wp_gf_form: Data: 0.01MB + Index: 0.00MB + Engine MyISAM
    wp_gf_form_meta: Data: 1.53MB + Index: 0.00MB + Engine MyISAM
    wp_gf_form_revisions: Data: 0.02MB + Index: 0.03MB + Engine InnoDB
    wp_gf_form_view: Data: 5.01MB + Index: 2.19MB + Engine MyISAM
    wp_links: Data: 0.02MB + Index: 0.02MB + Engine InnoDB
    wp_mgmlp_folders: Data: 0.03MB + Index: 0.03MB + Engine MyISAM
    wp_nextend_smartslider_layouts: Data: 0.00MB + Index: 0.00MB + Engine MyISAM
    wp_nextend_smartslider_sliders: Data: 0.00MB + Index: 0.00MB + Engine MyISAM
    wp_nextend_smartslider_slides: Data: 0.15MB + Index: 0.00MB + Engine MyISAM
    wp_nextend_smartslider_storage: Data: 0.03MB + Index: 0.01MB + Engine MyISAM
    wp_options: Data: 2.41MB + Index: 0.17MB + Engine InnoDB
    wp_postmeta: Data: 11.52MB + Index: 3.03MB + Engine InnoDB
    wp_posts: Data: 1.52MB + Index: 0.42MB + Engine InnoDB
    wp_responsive_menu: Data: 0.05MB + Index: 0.00MB + Engine InnoDB
    wp_rg_form: Data: 0.00MB + Index: 0.00MB + Engine MyISAM
    wp_rg_form_meta: Data: 0.85MB + Index: 0.00MB + Engine MyISAM
    wp_rg_form_view: Data: 2.52MB + Index: 2.00MB + Engine InnoDB
    wp_rg_incomplete_submissions: Data: 0.00MB + Index: 0.00MB + Engine MyISAM
    wp_rg_lead: Data: 1.52MB + Index: 0.17MB + Engine InnoDB
    wp_rg_lead_detail: Data: 2.52MB + Index: 5.05MB + Engine InnoDB
    wp_rg_lead_detail_long: Data: 0.15MB + Index: 0.01MB + Engine MyISAM
    wp_rg_lead_meta: Data: 2.02MB + Index: 0.14MB + Engine MyISAM
    wp_rg_lead_notes: Data: 0.00MB + Index: 0.00MB + Engine MyISAM
    wp_signups: Data: 0.02MB + Index: 0.06MB + Engine InnoDB
    wp_termmeta: Data: 0.07MB + Index: 0.05MB + Engine MyISAM
    wp_terms: Data: 0.06MB + Index: 0.03MB + Engine InnoDB
    wp_term_relationships: Data: 0.16MB + Index: 0.09MB + Engine InnoDB
    wp_term_taxonomy: Data: 0.08MB + Index: 0.09MB + Engine InnoDB
    wp_usermeta: Data: 7.52MB + Index: 4.03MB + Engine InnoDB
    wp_users: Data: 0.38MB + Index: 0.28MB + Engine InnoDB
    wp_wc_admin_notes: Data: 0.02MB + Index: 0.00MB + Engine InnoDB
    wp_wc_admin_note_actions: Data: 0.02MB + Index: 0.02MB + Engine InnoDB
    wp_wc_category_lookup: Data: 0.02MB + Index: 0.00MB + Engine InnoDB
    wp_wc_customer_lookup: Data: 0.02MB + Index: 0.03MB + Engine InnoDB
    wp_wc_download_log: Data: 0.00MB + Index: 0.00MB + Engine MyISAM
    wp_wc_order_coupon_lookup: Data: 0.02MB + Index: 0.03MB + Engine InnoDB
    wp_wc_order_product_lookup: Data: 0.02MB + Index: 0.06MB + Engine InnoDB
    wp_wc_order_stats: Data: 0.02MB + Index: 0.05MB + Engine InnoDB
    wp_wc_order_tax_lookup: Data: 0.02MB + Index: 0.03MB + Engine InnoDB
    wp_wc_product_meta_lookup: Data: 0.05MB + Index: 0.09MB + Engine InnoDB
    wp_wc_reserved_stock: Data: 0.02MB + Index: 0.00MB + Engine InnoDB
    wp_wc_tax_rate_classes: Data: 0.02MB + Index: 0.02MB + Engine InnoDB
    wp_wc_webhooks: Data: 0.00MB + Index: 0.00MB + Engine MyISAM
    wp_wfBadLeechers: Data: 0.00MB + Index: 0.00MB + Engine MyISAM
    wp_wfBlockedCommentLog: Data: 0.00MB + Index: 0.00MB + Engine MyISAM
    wp_wfBlockedIPLog: Data: 0.00MB + Index: 0.00MB + Engine MyISAM
    wp_wfBlocks: Data: 0.00MB + Index: 0.00MB + Engine MyISAM
    wp_wfBlocks7: Data: 0.00MB + Index: 0.00MB + Engine MyISAM
    wp_wfBlocksAdv: Data: 0.00MB + Index: 0.00MB + Engine MyISAM
    wp_wfConfig: Data: 0.52MB + Index: 0.01MB + Engine MyISAM
    wp_wfCrawlers: Data: 0.00MB + Index: 0.00MB + Engine MyISAM
    wp_wfFileChanges: Data: 0.00MB + Index: 0.00MB + Engine MyISAM
    wp_wfFileMods: Data: 0.00MB + Index: 0.00MB + Engine MyISAM
    wp_wfHits: Data: 0.00MB + Index: 0.00MB + Engine MyISAM
    wp_wfHoover: Data: 0.00MB + Index: 0.00MB + Engine MyISAM
    wp_wfIssues: Data: 0.00MB + Index: 0.00MB + Engine MyISAM
    wp_wfKnownFileList: Data: 0.67MB + Index: 0.09MB + Engine MyISAM
    wp_wfLeechers: Data: 0.00MB + Index: 0.00MB + Engine MyISAM
    wp_wfLiveTrafficHuman: Data: 0.00MB + Index: 0.00MB + Engine MyISAM
    wp_wfLockedOut: Data: 0.00MB + Index: 0.00MB + Engine MyISAM
    wp_wfLocs: Data: 0.00MB + Index: 0.00MB + Engine MyISAM
    wp_wfLogins: Data: 0.00MB + Index: 0.00MB + Engine MyISAM
    wp_wfNet404s: Data: 0.00MB + Index: 0.00MB + Engine MyISAM
    wp_wfNotifications: Data: 0.02MB + Index: 0.00MB + Engine MyISAM
    wp_wfPendingIssues: Data: 0.00MB + Index: 0.00MB + Engine MyISAM
    wp_wfReverseCache: Data: 0.00MB + Index: 0.00MB + Engine MyISAM
    wp_wfScanners: Data: 0.00MB + Index: 0.00MB + Engine MyISAM
    wp_wfSNIPCache: Data: 0.00MB + Index: 0.00MB + Engine MyISAM
    wp_wfStatus: Data: 0.00MB + Index: 0.00MB + Engine MyISAM
    wp_wfThrottleLog: Data: 0.00MB + Index: 0.00MB + Engine MyISAM
    wp_wfVulnScanners: Data: 0.00MB + Index: 0.00MB + Engine MyISAM
    wp_yoast_indexable: Data: 2.52MB + Index: 0.78MB + Engine InnoDB
    wp_yoast_indexable_hierarchy: Data: 0.09MB + Index: 0.14MB + Engine InnoDB
    wp_yoast_migrations: Data: 0.02MB + Index: 0.02MB + Engine InnoDB
    wp_yoast_primary_term: Data: 0.02MB + Index: 0.03MB + Engine InnoDB
    wp_yoast_seo_links: Data: 0.05MB + Index: 0.01MB + Engine MyISAM
    wp_yoast_seo_meta: Data: 0.04MB + Index: 0.04MB + Engine MyISAM
    
    ### Post Type Counts ###
    
    acf: 6
    acf-field: 15
    acf-field-group: 9
    amn_mi-lite: 3
    attachment: 1869
    feedback: 3
    header_row_images: 2
    installation: 8
    mc4wp-form: 1
    mgmlp_media_folder: 147
    nav_menu_item: 175
    nivoslider: 1
    oembed_cache: 6
    page: 69
    post: 2
    product: 219
    shop_coupon: 4
    shop_order: 84
    soliloquy: 4
    wp-help: 10
    wp_block: 11
    
    ### Security ###
    
    Secure connection (HTTPS): ✔
    Hide errors from visitors: ✔
    
    ### Active Plugins (1) ###
    
    WooCommerce: by Automattic – 4.9.1
    
    ### Inactive Plugins (0) ###
    
    ### Dropin Plugins (1) ###
    
    advanced-cache.php: advanced-cache.php
    
    ### Must Use Plugins (4) ###
    
    Force Strong Passwords - WPE Edition: by Jason Cosper – 1.6.4
    WP Engine Seamless Login Plugin: by WP Engine – 1.5.5
    WP Engine Security Auditor: by wpengine – 1.0.9
    WP Engine System: by WP Engine – 4.1.0
    
    ### Settings ###
    
    API Enabled: ✔
    Force SSL: ✔
    Currency: USD ($)
    Currency Position: left
    Thousand Separator: ,
    Decimal Separator: .
    Number of Decimals: 2
    Taxonomies: Product Types: external (external)
    grouped (grouped)
    simple (simple)
    variable (variable)
    
    Taxonomies: Product Visibility: exclude-from-catalog (exclude-from-catalog)
    exclude-from-search (exclude-from-search)
    featured (featured)
    outofstock (outofstock)
    rated-1 (rated-1)
    rated-2 (rated-2)
    rated-3 (rated-3)
    rated-4 (rated-4)
    rated-5 (rated-5)
    
    Connected to WooCommerce.com: ✔
    
    ### WC Pages ###
    
    Shop base: #2186 - /medical-storage/
    Cart: #3727 - /cart/
    Checkout: #3729 - /checkout/
    My account: #3731 - /my-account/
    Terms and conditions: #1501 - /terms/
    
    ### Theme ###
    
    Name: Twenty Twenty
    Version: 1.6
    Author URL: https://wordpress.org/
    Child Theme: ❌ – If you are modifying WooCommerce on a parent theme that you did not build personally we recommend using a child theme. See: How to create a child theme
    WooCommerce Support: ✔
    
    ### Templates ###
    
    Overrides: –
    
    ### Action Scheduler ###
    
    Canceled: 1
    Oldest: 2021-01-22 10:01:15 -0500
    Newest: 2021-01-22 10:01:15 -0500
    
    Complete: 26
    Oldest: 2020-12-26 13:34:08 -0500
    Newest: 2021-01-22 13:10:22 -0500
    
    Pending: 2
    Oldest: 2021-01-24 12:48:02 -0500
    Newest: 2021-01-24 12:48:02 -0500
    
    
Viewing 15 replies - 16 through 30 (of 32 total)
  • designinvento

    (@designinvento)

    Hi,
    A simple fix would can be implement by adding option to wp_options table
    if (!get_option(‘wc_remote_inbox_notifications_specs’)){
    add_option(‘wc_remote_inbox_notifications_specs’, ”);
    }

    proposed fix for next update:
    A conditions should be added to check if wc_remote_inbox_notifications_specs exists in run method

    Plugin Support Shaun Kuschel a11n

    (@shaunkuschel)

    Automattic Happiness Engineer

    Thanks everyone for the info related to this issue. The devs have been made aware and will be looking into this.

    tracyandersonmd

    (@tracyandersonmd)

    Bummer. Just updated to Woocommerce 4.9.2, assuming that they were on this issue. The update did NOT resolve the problem for product updates, only the issue with deactivation of plugins. How can that be?

    I removed and then reinstalled the functions.php hack to get functionality back.

    Ilyas Foo

    (@ilyasfoo)

    I have confirmed that devs have shipped a fix in the woocommerce.com server. This was caused by a unicode character used in RemoteInboxNotification feature was not compatible with the site’s option_value database collation. You should not encounter this issue anymore, please let us know if otherwise.

    Further fixes will be made to ensure this kind of problem will never cause the site to be unresponsive again. Sorry for the inconvenience caused!

    tracyandersonmd

    (@tracyandersonmd)

    @ilyasfoo As I said yesterday, the update resolved only the plugin issue, not the more important product issue.

    gonsurfn77

    (@gonsurfn77)

    I am still not able to update any pages or products. This is killing me….will there be a patch to WooCommerce soon to fix this issue? It has been almost a month now and I have to disable Woo anytime I need to update a page…and cannot update products. I read the thread but not exactly sure where to place the needed workaround code mentioned…

    Matt

    (@pkimatt)

    @gonsurfn77 The code would be placed in functions.php of your theme.

    gonsurfn77

    (@gonsurfn77)

    Thanks Matt. Is there a specific place within the theme’s functions.php that this should be added? I used the first set of code (simpler) provided and // out the line 69 and 70 as listed in woo… but no change…still cannot edit pages.

    Thread Starter mikedev

    (@mikedev)

    Reply by @ilyasfoo is valid for me. Errors no longer exist when saving a product or activate/deactivate any plugin.

    gonsurfn77

    (@gonsurfn77)

    I am not a developer but I followed the instructions the best I could. When I added the code to my theme’s functions.php and // the lines 69 and 70 in WooCommerce as stated, I now get the following error shown on the page. Is there a specific spot within the functions.php that the code must be placed at? Ready to hire one of you to fix this even if it is a temp fix…this is killing me….

    Warning: Invalid argument supplied for foreach() in /home/salsadmin123/public_html/wp-content/plugins/woocommerce/packages/woocommerce-admin/src/Loader.php on line 226

    Ilyas Foo

    (@ilyasfoo)

    Hi @tracyandersonmd @gonsurfn77, the product issue should be fixed without having to update WooCommerce plugin, because the fix is on server json file unless the problem that you’re facing is caused by a different issue altogether. I have tried to reproduce again with a site that had the original problem but was able to create & update products.

    If you’re still having a similar problem and you think it might be a bug, I would appreciate it if you can report the details in a new issue, thanks!

    Matt

    (@pkimatt)

    @gonsurfn77 Anywhere should be fine in the functions.php file for the fix I posted. I would try undoing both though and see if that error still persists.

    tracyandersonmd

    (@tracyandersonmd)

    @ilyasfoo Thank you very much. Everything is now back in order. Cheers!

    @ilyasfoo @pkimatt

    The plugin is updated and I still cannot edit any pages or products. I removed the code snippet provided as well and still no luck. Anyone for hire??

    Here is the error I get when I added the code below to my theme’s functions.php file…

    //woocommerce fix
    add_filter(‘woocommerce_admin_features’, ‘pk_woocommerce_admin_features’);
    function pk_woocommerce_admin_features($features) {
    if(($key = array_search(‘remote-inbox-notifications’, $features)) !== false) {
    unset($features[$key]);
    }
    }

    Warning: Invalid argument supplied for foreach() in /home/salsadmin123/public_html/wp-content/plugins/woocommerce/packages/woocommerce-admin/src/Loader.php on line 226

    If I disable, Woocommerce, everything works fine..

    @gonsurfn77 Hmmm that sounds like it may be unrelated?

    I would try downloading the Woocommerce plugin fresh from the WordPress.org plugin repository and uploading all of the files again. If that doesn’t work I’d be willing to take a look and help you out.

Viewing 15 replies - 16 through 30 (of 32 total)
  • The topic ‘Product Save Times Out to 502 Error’ is closed to new replies.