Support » Plugin: WooCommerce » Product review tab missing

  • Resolved natanleon

    (@natanleon)


    I come across this issue after a vast research I can not find the answer.
    The review tab is missing. I can see the reviews on the backend in the comment section. And I’ve done anything possible to get it to show up on the front end but not a success. I have deactivated/activated plugins, change the theme, enabling customer review on wc settings as well as the theme. and absolutely nothing works. Any help from a developer, or an experienced person.

    • This topic was modified 6 months ago by  natanleon.

    The page I need help with: [log in to see the link]

Viewing 8 replies - 1 through 8 (of 8 total)
  • You can please enable review from admin panel Admin Panel > WooCommerce > Settings > General > Enable Enable reviews then it should work fine.

    natanleon

    (@natanleon)

    I have tried that already and still not working. Thanks for that.

    stefsterNYC

    (@stefsternyc)

    either someone wrote it out with a remove action in functions or they CSS’d it out. Posting a URL would be helpful

    It seems any custom code or plugin functionality disable review function. so disable plugin one by one and check it resolve your issue.

    Plugin Support John Coy

    (@johndcoy)

    Automattic Happiness Engineer

    Hi @natanleon

    That’s correct. Issues like this are typically caused by a theme or plugin conflict. Try switching back to a default theme like Twenty Seventeen and disable all plugins except for WooCommerce to see if this resolves the issue.

    If so, then re-enable each one at a time until you find the one that’s causing the conflict.

    natanleon

    (@natanleon)

    Thanks guys, I will try that again and let you know.

    I deactivated all plugins and theme and the problem didn’t change
    What I had to do is go product by product on the product section of backend and click the quick edit button and then tick “Enable review” and update button at the bottom right corner, and that solved the issue the problem is when you have about 500 products then it’s time-consuming. if anyone else knows any other quicker way to fix this. please let me know. Keep in mind in WC setting on the product tab review has to be enabled as well as on the customizer of the theme is the theme is compatible with woocommerce.

    Thanks for helping out

    TiffanyH

    (@tiffanyh)

    Thanks, @natanleon your solution worked for me. Fortunately, our shop only has 25 products so wasn’t so bad. I did find the field in my database (phpMyAdmin) ‘wp_woocommerce_order_itemmeta’ then in mine it’s meta_key “rate_id” with enabled meta_value should have a 1. I don’t know how to do this, but you can probably create and run a script to change all to a 0 then run a script again to replace all with a 1.

Viewing 8 replies - 1 through 8 (of 8 total)
  • You must be logged in to reply to this topic.