WordPress.org

Forums

WooCommerce - excelling eCommerce
[resolved] Product page gives 404 error after 2.1 update (6 posts)

  1. indira14
    Member
    Posted 1 year ago #

    After updating to WooCommerce 2.1 my product page is giving a 404 error. I already re-saved the permalinks, but that did not work.

    Example:

    http://toko4all.nl/woo/shop/cadeau-hoek/polvoron-pakket/

    (If it's not showing, please set the language to Dutch instead of English).

    What should I do?

    https://wordpress.org/plugins/woocommerce/

  2. indira14
    Member
    Posted 1 year ago #

    Tried out some stuff and noticed the following:

    I was using Custom Base: /shop/%product_cat%/ for product permalink.

    Changing it to Product made my product pages show up again.

    Hope this error will be fixed in a next version of the plugin. I liked the way my permalinks were before.

  3. Coen Jacobs
    Member
    Posted 1 year ago #

    The WooCommerce 2.1.1 fix release resolves a couple issues with permalinks, probably yours too. Please let me know if this issue persists for you after the update to 2.1.1 and manually flushing your permalinks (via Settings > Permalinks in your WordPress administration panel).

  4. justinrogers
    Member
    Posted 1 year ago #

    I've upgraded to 2.1.1 and have tried manually flushing (pressing Save) the permalinks and I'm still getting 404 errors on Shop page and all products. Any other thoughts to fixing this? Frustrating...

  5. Coen Jacobs
    Member
    Posted 1 year ago #

    Stop hijacking other peoples threads please. Make your own (as per forum policy).

  6. indira14
    Member
    Posted 1 year ago #

    I'm at the latest version and the problem is still there unfortunately, even after flushing them again.

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • WooCommerce - excelling eCommerce
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic