Support » Plugin: Accept Stripe Payments » Product options error

  • I’m seeing an error in the product options page but it doesnt seem to be affecting anything as far as I can tell. Any ideas?

    wp-content/plugins/stripe-payments/admin/includes/class-products-meta-boxes.php on line 68

    Line 68 says:
    call_user_func( array( $box[‘callback’][0], $box[‘callback’][1] ), $post );

Viewing 9 replies - 1 through 9 (of 9 total)
  • Plugin Support mbrsolution

    (@mbrsolution)

    Hi, thank you for reporting this error. The plugin developers will investigate further your findings.

    Thank you

    Plugin Contributor Alexander C.

    (@alexanderfoxc)

    Hi.

    Can you provide the actual error message? Is it notice, warning etc. This would be helpful in trying to reproduce the issue (currently I see no errors on product edit page).

    Thread Starter patsky

    (@patsky)

    It is a warning:

    Warning: call_user_func() expects parameter 1 to be a valid callback, first array member is not a valid class name or object in /homepages/xx/xxxxxxx/xxxx/xxxxx/wp-content/plugins/stripe-payments/admin/includes/class-products-meta-boxes.php on line 68

    It appears in the Edit Product screen under Product options in the rh box where the options appear when you click one of the headings. Once yiou click a heading it disappears. It doesn’t appear to be causing a problem on the face of it.

    Plugin Contributor Alexander C.

    (@alexanderfoxc)

    Could be a conflict with some other plugin that puts its metabox on product edit page.

    I couldn’t reproduce it, however added a condition to that part of the code that checks if the function is callable before trying to call it. This should fix the warning.

    Version 2.0.17 (which is coming shortly) will have this fix included.

    Thank you for reporting.

    Thread Starter patsky

    (@patsky)

    Thanks – however the message is gone but it isn’t working at all now! I can create a product but When I try and click a setting it just throws me back to the top of the page.

    I’ll revert for now till I find out if there’s a conflict.

    Plugin Contributor Alexander C.

    (@alexanderfoxc)

    This is definitely a conflict.

    Try disabling your other plugins one by one until the error is gone. Let me know which was the latest plugin you disabled, possibly it’s the one causing the conflict. I’ll install it on my test server to be able to reproduce the issue and fix it.

    Thread Starter patsky

    (@patsky)

    Quick response!

    I have found the culprit – Advanced Custom Fields – https://wordpress.org/plugins/advanced-custom-fields/

    Sorry should have tried that earlier…no rush…I don’t now need that plugin πŸ˜‰

    • This reply was modified 1 year, 9 months ago by patsky.
    Plugin Contributor Alexander C.

    (@alexanderfoxc)

    Thank you. I was able to reproduce the issue and apply the fix.

    It would be included in the upcoming version 2.0.18, which is coming shortly.

    Even if you don’t need the plugin, the conflicts should be avoided anyway. When plugins coexist in peace, they can do much more useful stuff, unlike when they’re in conflict with each other πŸ˜‰

    Thread Starter patsky

    (@patsky)

    Thank you so much. This is a fabulous plugin. It would be nice if there were a few more global settings such as Collect Address and Appearance but it works perfectly.

    Thanks and great support. I need to write a review!

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Product options error’ is closed to new replies.