Support » Plugin: Facebook for WooCommerce » Product is not uploaded. Missing fields

  • Resolved hungpham

    (@hungpham)


    I am running WooCommerce 4.0.1, and Facebook for WooCommerce 1.10.2. After clicking sync products, nothing is uploaded to FB shop.

    The product is shown in FB catalog, but product data source shows error:

    A product is missing a field: variant_value
    A product is missing a field: variant_label
    A product is missing a field: google_product_category

    Something wrong with this plugin, or Facebook?

    Thanks.

Viewing 9 replies - 1 through 9 (of 9 total)
  • Plugin Author SkyVerge

    (@skyverge)

    Hey @hungpham,

    Thanks so much for contacting us! I’d be happy to help.

    As a first step, could you please confirm if any of these products are virtual products? Facebook’s commerce policies don’t support listing virtual products, so that might explain why you’re encountering issues with products of that type.

    Could you please double-check to see if this applies to your products? If not, please let me know – I’d be happy to continue troubleshooting.

    Cheers,
    Lindsey

    Thread Starter hungpham

    (@hungpham)

    Hi Lindsey.

    No, I only have one product for now. I set it up as a simple product, without checking to the virtual or downloadable box. The product is a printed book.

    Plugin Author SkyVerge

    (@skyverge)

    Hey @hungpham,

    Thanks for following up! I’ve been researching these issues and it looks like it’s a warning, rather than an error, so you should still be able to display the product in your Facebook shop. Can you confirm if that’s possible right now?

    I’ll check with some folks on my team to see if we can determine how to remove the warnings, but it looks as though this shouldn’t block you from selling the product in Facebook.

    Could you please let me know if that product is displayed in the Shop section of your connected Facebook page?

    Cheers!
    Lindsey

    Thread Starter hungpham

    (@hungpham)

    Hi Lindsey.

    I already mentioned at the beginning, that nothing is uploaded to FB shop. That’s why I am asking here.

    Plugin Author SkyVerge

    (@skyverge)

    Hey @hungpham,

    My apologies for not being clearer! What I meant was that it sounds like the products are uploaded correctly to your catalog, so now we need to ensure that the catalog is connected properly to the shop.

    If you go to facebook.com/products, select the catalog, and then click Use Cases, you should see a “Facebook Page Shop” option. If you select that option, you should then be able to click Connect Page to link this catalog with the Shop area on your Facebook Page.

    Could you please try that out and let me know if this sets up your shop successfully?

    Cheers!
    Lindsey

    Thread Starter hungpham

    (@hungpham)

    Hi Lindsey.

    When I am using this plugin, it’s creating a new catalog, named “mybusiness – WooCommerce”, beside the default catalog “Products for mybusiness”.

    And the Facebook Page Shop option only appears in the catalog “Products for mybusiness”, while sync’ing from this plugin created a product in the catalog “mybusiness – WooCommerce”.

    I even tried to disconnect the FB page from the catalog “Products for mybusiness”, but there is no option for connecting my FB page to the new catalog “mybusiness – WooCommerce”.

    I think that’s why the product is not uploaded to the FB shop.

    A little confusion. Hope that you can see the problem here?

    Plugin Author SkyVerge

    (@skyverge)

    Hey @hungpham,

    Thanks for following up!

    Could you please confirm that you followed the steps in this guide to disconnect your old catalog and then connect the new catalog generated by Facebook for WooCommerce (i.e. the one with “- WooCommerce” in the catalog name)?

    Thanks for your patience while we troubleshoot!

    Cheers!
    Lindsey

    Thread Starter hungpham

    (@hungpham)

    Hi Lindsey.

    Yes, I manually disconnected the default, and re-connect to the new WooCommerce catalog, then the product upload is working now.

    Might be you can change the code to do this step automatically, so we don’t need to do manually again for other websites?

    Thanks.

    Plugin Author SkyVerge

    (@skyverge)

    Hey @hungpham,

    Great! Thanks so much for confirming this for me. I’m glad we were able to get to the bottom of this one.

    I’ll share your experience with my team to see if it’d be possible for us to let you select the catalog for your page during the Facebook for WooCommerce setup – I can see how that would have saved a lot of time here!

    Could you please let me know if there’s anything else I can do for you?

    Cheers!
    Lindsey

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Product is not uploaded. Missing fields’ is closed to new replies.