Support » Plugin: WP Multilang » Product in 2nd lang not showing

  • Resolved s56vha

    (@s56vha)


    Hello

    I use 2 lang., English (default) and Slovenian (SL = slovenščina).
    Products in EN are shown ok, product in SL are shown if I go to the direct link of a product. If I go to SHOP (SL: trgovina), products are shown, but when I click on it i get “oops, that page canot be found.”

    I see that the problem is in link translation (EN product = SL izdelek):
    EN: domain/product/product-1/ – working
    SL: domain/sl/izdelek/product-1/ – not working
    direct link to product from backend: domain/sl/product/product-1/ – working

    PS: the flag is wrong

    Please advise,
    Ales

    The page I need help with: [log in to see the link]

Viewing 14 replies - 1 through 14 (of 14 total)
  • Plugin Author VaLeXaR

    (@valexar)

    Hi s56vha.
    What version of WooCommerce You are using?
    Did You set up WooCommerce permalinks?

    • This reply was modified 4 years, 3 months ago by VaLeXaR.
    Thread Starter s56vha

    (@s56vha)

    WP ver: 4.8.2
    WC ver: 3.1.2
    theme: The7 ver. 3.3.0

    Product permalink:
    was: default: domain/product/sample-product/ – EN = OK, SL: name “product” in link was translated by plugin to SL “izdelek”, so link was not working

    now: I changed to “Shop base”, so the link is domain/shop/sample-product/ – name “shop” is not translated by your plugin – so it is woring with that setting

    What about the flag – where I can change it in backend? What about flag/lang in frontend?

    Thank you for the help!

    Plugin Author VaLeXaR

    (@valexar)

    WP Multilang do not support different permalinks for each language.
    Flag You cat set up in General Settings.
    http://prntscr.com/guq0nl

    Thread Starter s56vha

    (@s56vha)

    Jea, I changed the flag, but it changed back ?? I will change again.

    What about flag/lang in frontend – is that possible?

    thank you.

    Plugin Author VaLeXaR

    (@valexar)

    What you mean flag in frontend?
    You can display language switcher from menu, widget or function.

    Thread Starter s56vha

    (@s56vha)

    I don’t use side bar in home page, footer is not visible enough, so lang switcher widged in not for me.
    Any possibility to add lang swither to header/menu with flag. I if add lang in a menu there is just a name and link to other lang, no flag.

    • This reply was modified 4 years, 3 months ago by s56vha.
    Plugin Author VaLeXaR

    (@valexar)

    Are You set up menu item setting http://prntscr.com/gvapdn ?
    In menu on frontend http://prntscr.com/gvaq1w.

    Thread Starter s56vha

    (@s56vha)

    I tried several times, but no flag, just name in menu 🙁

    Plugin Author VaLeXaR

    (@valexar)

    Do you have flags in your html code? http://prntscr.com/gw85qo
    Maybe, images hidden in css?

    Thread Starter s56vha

    (@s56vha)

    Sorry, no flag. I solved lang switch with custom link in menu without flag.

    Plugin Author VaLeXaR

    (@valexar)

    Can You show screenshot with html code of language menu item?

    Thread Starter s56vha

    (@s56vha)

    I didn’t found that code, you can check on site: http://shop.geomina.si/

    Ther is another problem with menu:
    1. menu is OK – no lang option, just custom links and other menus – pic1
    2. adding lang. – pic2
    3. lang settings – pic3
    4. menu with lang switch – pic4

    Plugin Author VaLeXaR

    (@valexar)

    Try reinstall WP Multilang. Remove from wp_options table a row with option name ‘wpm_version’. And the plugin will update all own configs.

    Thread Starter s56vha

    (@s56vha)

    Hi

    I updated the plugin – still the same problem. Never mind, I will use custom link and no flag.
    Thank you.

Viewing 14 replies - 1 through 14 (of 14 total)
  • The topic ‘Product in 2nd lang not showing’ is closed to new replies.