Support » Theme: Astra » Product Image Gallery on single product page

  • Hello, I’m having some issues with the product image gallery. The images in single product page don’t seem to be cropped as they should be and instead they’re displaying at original height, so all different sizes. Not a custom ratio of 4:3 as set in Astra settings.

    See video showing: https://drive.google.com/file/d/1GK4aGJ9dvfKgWo4sExkRBSyICNS8h9m7/view?usp=sharing

    I have regenerated thumbnails to be sure this isn’t the issue. There is no way to control the height of the image within elementor element either.

    Elementor support have said that it’s Astras settings overriding this.

    Many thanks in advance.

    The page I need help with: [log in to see the link]

Viewing 3 replies - 1 through 3 (of 3 total)
  • Hi @sophierose,

    The configuration you showed in the video, that will affect the image used for products in the catalog not the product image in the single product page.

    The single product image will be displayed as uploaded. Please refer to this topic. If you want the single product image to be a square, then you need to upload a square image.
    
    I hope that will help.

    Kind regards,
    Herman 🙂

    Hi Herman,

    Thanks a lot for your reply. Unfortunately my client can’t upload square images, which leads me still needing to crop them. That plugin in the link isn’t working for me either. I’ve tried to add to my functions.php manually:

    add_filter( 'woocommerce_get_image_size_single', function( $size ) {
    	return array(
    		'width'  => 600,
    		'height' => 600,
    		'crop'   => 1,
    	);
    } );
    

    But I have had no luck, I have regenerated thumbnails again and clear cache, why is this function not working with Astra when I’ve tested and it works with other themes?

    Thanks so much!

    Hi @sophierose,
    
    Sorry for the long delay.

    I tried the code on my dev site and it worked. Please refer to this video – https://share.getcloudapp.com/bLujOvLX
    
    If it didn’t work for you, then there’s must be something caused the code didn’t work, plugin or another custom code?
    
    I hope that will help.

    Kind regards,
    Herman 🙂

    P.S. We recommend reaching out to us through our Support Portal for faster and quicker help and resolution as mentioned here.

Viewing 3 replies - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.