Support » Plugin: WooCommerce » Product gallery missing

  • Resolved avz

    (@avz)


    Hi,

    The 3.6 update broke the login and cart function. 3.6.1. fixed this.
    But now the product gallery is not showing up. We use 3 images per product but only the main image is shown.

    Is there a fix for this?

Viewing 15 replies - 1 through 15 (of 18 total)
  • rassoni

    (@rassoni)

    I have the same problem

    Plugin Author Mike Jolley

    (@mikejolley)

    Can you tell us which theme? Ideally we need a copy of the theme to see whats happening, and a link to the site.

    avz

    (@avz)

    Hi Mike,

    Thanks. We use the Astra theme (pro). Our website: https://bit.ly/2twM34i
    I rolled back to 3.5.8. So the gallery is working now.

    Plugin Author Mike Jolley

    (@mikejolley)

    @avz I found a copy of Astra (free) and the pro plugin which worked with the gallery under 3.6.0 but the layout was quite different to your example site.

    Do you have customisations in place and template overrides?

    avz

    (@avz)

    No custom work. But we picked the vertical gallery layout in our themes customizer.

    Plugin Author Mike Jolley

    (@mikejolley)

    @avz just found and tried that and all appears normal. Running 1.8.1.

    avz

    (@avz)

    I updated again but still the error occurs.
    See: https://bit.ly/2UnfDlq

    Plugin Author Mike Jolley

    (@mikejolley)

    @avz anyway we can get access to this to debug? There are a few users affected by this but I cannot replicate :/ I’d like to look into it further. You could get in touch via the WooCommerce helpdesk or mail me https://github.com/mikejolley and we can see what we can find.

    avz

    (@avz)

    I will ask. We have some extra layers of security.
    But i will try.

    Thanks

    coach-henk

    (@coach-henk)

    Same problem on my site. After update gallery is missing, tried to switch to storefront, also same problem.
    Another website with the same theme (Genesis Sample 2.3.0) is not affected.

    bgrgroup

    (@bgrgroup)

    Same for me
    I made similar theme here: missing-gallery

    Still not fixed.

    I have almost same functionality site serel.bg but not updated
    Wordpress 5.1.1
    BeTheme 21.1.5
    Woocommerce 3.5.7

    And there all products galleries works fine.

    bgrgroup

    (@bgrgroup)

    That works for me! Thank You!

    The issue is in /woocommerce-multilingual/inc/class-wcml-products.php
    Comment this line wp-content/plugins/woocommerce-multilingual/inc/class-wcml-products.php:689

    <code>$data[‘_product_image_gallery’] = null;</code>

    Looking forward for Woocommerce-multilingual update with fix

    allartsoftworks

    (@allartsoftworks)

    @bgrgroup you are my god! Thank you.

    coach-henk

    (@coach-henk)

    Was indeed the WPML problem. Commenting the code is the solution.

    bgrgroup

    (@bgrgroup)

    I just followed this advices and share it:

    workaround

    Regards

    • This reply was modified 7 months ago by bgrgroup.
Viewing 15 replies - 1 through 15 (of 18 total)
  • You must be logged in to reply to this topic.