Amazon Product in a Post Plugin
Product Does not Display (5 posts)

  1. Cassie Beyer
    Posted 1 year ago #

    I have gone through the directions over and over again. At first I got a very long error, but then I switched to CURL and now I simply get nothing at all. I have an access code and a secret code. I've double-checked for spaces at the beginning and end of them. I've switched to CURL. nothing works. I don't know where to even go from here.


  2. Cassie Beyer
    Posted 1 year ago #

    When I try another Amazon plugin, I get the following error:
    AWS Request Failed, please check keys - Error Message: Your AccessKey Id is not registered for Product Advertising API. Please use the AccessKey Id obtained after registering at https://affiliate-program.amazon.com/gp/flex/advertising/api/sign-in.html.

    I don't understand what that means. I have gone through the steps again and again. I have clicked on the link given to start the whole process again and again. I don't know what I am missing.

  3. sbbn
    Posted 1 year ago #

    I don't know if this will help, but here are two things I just came across when I had the same problem:

    1. The ASIN on Amazon Associates Page isn't the ASIN you need. Maybe this was just a fluke, but grabbing the ASIN from the Associates Page didn't work, only after I went out to the regular product page and cut & pasted that ASIN did everything show up.

    2. I also noticed that I used the wrong Access Key at first. When you go out to the IAM Management Console, you see your Access Key already there. I made the mistake of C&Ping that Key, then requesting a new Key and putting in the Secret Key from that rootkey.csv file without updating the Access Key. Does that make sense? Just make sure both Keys you used are the ones that were sent in the rootkey.csv file.

    Hope these help.

  4. CreationNation
    Posted 1 year ago #

    Thanks sbbn - I also used the Access Key I first saw (and old one) and then the new secret key.

    Seeing this I double checked, and sure enough.. Thanks!

  5. caroleighdeneen
    Posted 1 year ago #

    I had trouble with no product showing up and it turned out to be that my API account was not registered.

    I figured it out by using this scratch area from Amazon - which will tell you if your request fails:

    Posting here in case it can help others.

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Amazon Product in a Post Plugin
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic


No tags yet.