Support » Plugin: WooCommerce » Product Data – Product type field is unavailable, variations don’t work

  • Resolved Shaman

    (@stormman)


    Hey guys,
    After WordPress update I have a problem, and rollback somehow doesn’t help.

    On the admin product page, in the Product Data section, the Product Type field is there no more. I can’t make any product variable.

    I can’t see a way to attach screenshot here, therefore I’ll show the code:

    <div class="postbox-header">
    <h2 class="hndle ui-sortable-handle">Product data</h2>
    <!-- HERE SHOULD BE THE SELECT TYPE SECTION, CODE BELOW IS NOT RELEVANT TO THE QUESTION -->
    <div class="handle-actions hide-if-no-js"><button type="button" class="handle-order-higher" aria-disabled="false" aria-describedby="woocommerce-product-data-handle-order-higher-description"><span class="screen-reader-text">Move up</span><span class="order-higher-indicator" aria-hidden="true"></span></button><span class="hidden" id="woocommerce-product-data-handle-order-higher-description">Move Product data box up</span><button type="button" class="handle-order-lower" aria-disabled="false" aria-describedby="woocommerce-product-data-handle-order-lower-description"><span class="screen-reader-text">Move down</span><span class="order-lower-indicator" aria-hidden="true"></span></button><span class="hidden" id="woocommerce-product-data-handle-order-lower-description">Move Product data box down</span><button type="button" class="handlediv" aria-expanded="true"><span class="screen-reader-text">Toggle panel: Product data</span><span class="toggle-indicator" aria-hidden="true"></span></button></div></div>

    All the tabs for variations with class .show_if_variable have style=”display:none”.

    Another thing that has changed, not relevant to the topic but may have a clue: Yoast SEO section disappeared from the admin product page as well.

    WordPress 5.5
    WooCommerce 4.4.1

    Theme WoodMart 5.2.0

    What may be a reason for that?

    • This topic was modified 3 months ago by Shaman.
Viewing 6 replies - 1 through 6 (of 6 total)
  • Shaman

    (@stormman)

    That is what was going on in console on product page load:

    phive_common.js:1 Uncaught ReferenceError: JQuery is not defined
        at phive_common.js:1
    wp-color-picker-alpha.min.js:1 Uncaught ReferenceError: wpColorPickerL10n is not defined
        at wp-color-picker-alpha.min.js:1
        at wp-color-picker-alpha.min.js:1
    heartbeat.min.js:2 XHR finished loading: POST "https://impact-store.com/wp-admin/admin-ajax.php".
    send @ jquery.js:4
    ajax @ jquery.js:4
    l @ heartbeat.min.js:2
    (anonymous) @ heartbeat.min.js:2
    ?v=2.0:6 WebSocket connection to 'wss://public-api.wordpress.com/pinghub/wpcom/me/newest-note-data' failed: Error during WebSocket handshake: Unexpected response code: 403
    Plugin Support Fernando

    (@fhaps)

    Automattic Happiness Engineer

    @stormman WordPress 5.5 removed a javascript file called jquery-migrate. When a plugin installed on you site still tries to call on that deprecated file, it causes an issue like the one you are seeing.

    As a temporary fix, you may try installing the plugin Enable jQuery Migrate Helper. If this is indeed the issue, the plugin will re-enable those deprecated files and show you what plugin was the one causing the issue. I’d suggest contacting the plugin developer to alert them of the problem.

    Shaman

    (@stormman)

    Thanks for the reply, it seems like it’s not the issue: Enable jQuery Migrate Helper installed has’t changed the situation. What else could be the reason? That’s very strange, as the list of product types doesn’t even appear there at all…

    Shaman

    (@stormman)

    And in case you ask… I have tried to deactivate cache plugins, cleaned browser cache. The issue persists, doesn’t matter what I try.

    • This reply was modified 3 months ago by Shaman.
    Plugin Support Fernando

    (@fhaps)

    Automattic Happiness Engineer

    If the above didn’t work, you’ll want to run a full conflict test next.

    Temporarily switch your theme to Storefront. Then, disable ALL plugins on the site except for WooCommerce, and test for the issue.

    If the issue is gone, you’ll then have to re-enable features one by one, while testing for the issue; until you find out which one is causing this behavior.

    We recommend that these steps are taken on a staging site, which is a clone of your live site that you can modify without risking making any permanent damage to your live site. You can create it using a plugin like WP-Staging: https://wordpress.org/plugins/wp-staging/

    Plugin Support Fernando

    (@fhaps)

    Automattic Happiness Engineer

    We haven’t heard back from you in a while, so I’m going to mark this as resolved – if you have any further questions, you can start a new thread.

Viewing 6 replies - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.