Support » Plugin: WooCommerce » Product Category & Filter By Attribute Widgets Not Displaying Correctly

  • Resolved VickyTFC

    (@vickytfc)


    Hi

    Since I updated, the ‘Shop Sidebar’ category/filter by attribute widgets display oddly with an arrow underneath that expands with a list of text below.

    This occurs on all pages that have the ‘Shop Sidebar’.

    Is there something that I need to disable/edit for it to revert to the previous display of just the drop down menu.

    Thanks, Vicky

    The page I need help with: [log in to see the link]

Viewing 12 replies - 1 through 12 (of 12 total)
  • Plugin Support Rynald0s

    (@rynald0s)

    Automattic Happiness Engineer

    Hi @vickytfc!

    Since I updated, the ‘Shop Sidebar’ category/filter by attribute widgets display oddly with an arrow underneath that expands with a list of text below.

    Was this after updating WooCommerce core or your theme? It looks like your theme could be in need of an update.

    You can use the following CSS code to resolve it in the meantime:

    .select2-container--default .select2-selection__arrow:before {
        display: none;
    }

    This CSS can be added to the “Additional CSS” section that is found in your customizer.

    Cheers!

    Plugin Support Rynald0s

    (@rynald0s)

    Automattic Happiness Engineer

    Howdy!

    We haven’t heard back from you in a while, so I’m going to go ahead and mark this thread as resolved. If you have any other questions please start a new thread.

    Cheers!

    Hi

    I inserted that code into CSS section & it did nothing:(

    Any other suggestions?

    Thanks, Vicky

    Plugin Support Rynald0s

    (@rynald0s)

    Automattic Happiness Engineer

    Hi @vickytfc!

    Are you adding it below any other CSS code you already have in there?

    Please see the following screenshots:

    This is before adding the code:

    Screen Shot 2019 07 29 at 11 04 01

    And this is after adding the code:

    Screen Shot 2019 07 29 at 11 04 09

    Am I looking at the wrong thing?

    Cheers!

    Yes I added it below other CSS code. Not sure how to upload it tbh. All advice welcome.

    Thanks for your help with this. Turned out to be the Autoptimize plugin that was causing the issue. So I had to disable it, reluctantly.

    Turned out to be the Autoptimize plugin that was causing the issue. So I had to disable it, reluctantly.

    Well, in that case you could re-configure instead? 🙂

    First and foremost try to identify what is breaking stuff by just disabling CSS or JS or Image optimization (incl. lazyload). Once you know that, dive in and try identify what code/ files (CSS or JS) are responsible for the broken feature and try excluding that. If the problem is with JS, chances are you’ll find useful information on your browser’s developer console.

    There’s more info in the troubleshooting tips and info on exclusions in the AO FAQ.

    hope this helps,
    frank

    VickyTFC

    (@vickytfc)

    Hi @optimizingmatters

    I went through & disabled each function, to no avail.. As the plugin interferes regardless of disabling CSS, JS etc.

    Any idea if this will be in the pipeline to be fixed?

    Thanks, Vicky

    Optimizing Matters

    (@optimizingmatters)

    well, first step would be understanding what is actually happening. the fact the problem occurs regardless of disabling CSS, JS and that I cannot reproduce it on my development environment makes it a tad harder. do you have a non-production environment where you could leave things broken for me to look into?

    VickyTFC

    (@vickytfc)

    Unfortunately no, not without giving you site access. Which I’m not really open to.

    Would love to reactivate this plugin though. Please advise once this bug is fixed.

    Thanks, Vicky

    Optimizing Matters

    (@optimizingmatters)

    As I cannot reproduce there’s nothing to fix either Vicky 🙂

    Do note that I didn’t ask for access (I don’t log in to other people’s site in the context of free support), but to able to see the issue on a non-production environment. Let me know if you soemhow can make that happen 🙂

    VickyTFC

    (@vickytfc)

    Unfortunately I have bigger fish to fry atm, @optimizingmatters Once I sort those out I’ll come back to you. Thanks, Vicky

Viewing 12 replies - 1 through 12 (of 12 total)
  • You must be logged in to reply to this topic.