Support » Plugin: WooCommerce » Product Attributes disappeared

Viewing 14 replies - 1 through 14 (of 14 total)
  • Plugin Support Melinda

    (@melindahelt)

    Automattic Happiness Engineer

    Hi there!

    Could you explain if you any changes on your site from the time the variations were displaying properly and then they were not? Did you update any specific plugins or make any other changes?

    Additionally, sharing a copy of your Status Report (which you can read about at https://docs.woocommerce.com/document/understanding-the-woocommerce-system-status-report/) will help us see what’s going on with your site.

    Hi, this is solved, I got a solution from one backend developer. He said that he has saw this problem on multiple websites. Solution is to add new random attribute in products > attributes and after I have done that all my old attributes and variations were back.

    Plugin Support Jesse Pearson

    (@jessepearson)

    Automattic Happiness Engineer

    @mare13ki Thank you for letting us know, I will mark the thread as resolved.

    I had the exact same problem and effect.

    This is clearly some kind of a caching / indexing bug.

    Do we know of any relevant GitHub tickets?

    I have just seen the exact same issue here.

    Several Hundred Colours and Sizes have disappeared from the Products > Attributes section.

    The Tables however seem fine, heaps of records in there.

    Also I am unable to do any Price updates, presumably due to the system thinking there are no Sizes and Colours.

    Is there a fix for this apart from just trying to add a random attribute ?

    Upgraded to / running 3.4.5

    I too am having this issue and I have not been able to resolve it. I have tried adding a new attribute in the product/attribute section and it did not resolve the issue.

    • This reply was modified 10 months, 2 weeks ago by acutech.

    ooof I have the same problem right now 🙁 I tried adding random attributes but it didnt help. Only the new attributes I added are displayed.

    hey, for anyone having this issue.

    I just solved it for a client of mine after a migration by re-creating the same attributes back in one by one and then clicking on them. it will force the application to look for the items.

    cabinetknobsandmore

    (@cabinetknobsandmore)

    I created my attributes but I am having a difficult time adding them to the PRODUCTS I go to simple product, than attributes. i click on save and than update attributes do not show on site. visible on site is checked
    all products in this category have the same finishes with the same price

    @cabinetknobsandmore are you having this issue after a site migration?

    cabinetknobsandmore

    (@cabinetknobsandmore)

    everything was working fine for years

    @cabinetknobsandmore when you go to simple product > attributes

    Do you see a drop-down that says custom product attributes?

    Do you see your attributes listed?

    Are you selecting the atribute from the dropdown, clicking add and then hitting save?

    Just trying to figure out where you’re at through chat.

    sht! Happens with me. How to resolve? When this bug will be fixed??

    Just happened to me. Lost all attributes created in the past 3 months after making a few changes in my htaccess file and disabling my CDN and server cache.
    The solution that @mare13ki suggested about adding a random attribute fixed the issue and my attributes came back and my products had those attributes set back again.
    Thank you so much @mare13ki for sharing the info, it saved me too much time.

Viewing 14 replies - 1 through 14 (of 14 total)
  • You must be logged in to reply to this topic.