Support » Plugin: WooCommerce Multilingual - run WooCommerce with WPML » Product Attribute Translations Not Saving

  • Resolved bluantinoo

    (@bluantinoo)


    Hello,
    I’m unable to translate product attribute via Woocommerce Multilingual interface.
    I go in WPML -> Woocommerce Multilingual -> attribute tab (ex: Weight)
    I click on “translate” string under my language
    I enter the double translation (singular and plural)
    I click “sync attributes and update all product variations”
    It looks like it’s working, I see the syncing countdown arriving to zero, and then I see the completed message.

    But the string is not translated in frontend, and if I come back in woocommerce multilingual to look again, translations are lost and I see again the red string “translate” under my language.

    On the contrary, if I translate the attribute using the standard WPML string translation: WPML -> string translation –> search the string
    it works:
    I find the 2 strings of Singular and Plural attribute name (marked as “taxonomy general name” amd “taxonomy plural name”), I apply the translations, click on save, and everything looks fine on frontend (while in woocommerce multilingual I still see the red string “translate”).

    This is the firs time I use Woocommerce Multilingual so, maybe I did miss something?

    https://wordpress.org/plugins/woocommerce-multilingual/

Viewing 15 replies - 1 through 15 (of 24 total)
  • Hello,

    Thank you for reporting your issue.
    Can you please tell me which version of our plugins are you using?

    Hey,
    I do have the same problem. Single values for an attribute can be translated and get saved, but not the main attribute name. So if I have the english attribute “Color” with values “brown,black,yellow” I can translate the values to “braun,schwarz,gelb” but not the main attribute title to “Farbe” and plural form “Farben”. It simply is not saved. Plugin Version is latest from repository i.e. version 3.6

    Hello,

    Our developers are aware of the problem and it will be solved in version 3.2.
    Below you can find a link to our Errata page where the problem is described:
    https://wpml.org/errata/translating-taxonomy-labels-problems/

    If you created the taxonomies in question prior to upgrading WPML String Translation, then you can likely still translate them from the String Translation admin screen. Simply look for strings named ‘taxonomy general label’ and ‘taxonomy singular label’ and translate these.

    Regards,
    Maciej

    Any idea when 3.2 is coming out? This is a critical issue for us and produces problems with other plugins – for example advanced filter for woocommerce.
    Regards,
    Johannes

    I have the same problem, expected timing of release?
    Thanks,
    Marek

    Message from WPML support – yesterday… Release 3.2 will be available this week.

    WPML 3.2 Release Candidate

    Should be released this week …

    WPML 3.2 Release Candidate

    WPML 3.2 Release Candidate is only available from your WPML account in the Download section. The CMS Beta package ZIP contains ZIP files of all of WPML’s components.
    We expect to release the final version in two weeks from now.

    Regards,
    Maciej

    Same problem here.

    Plugin Author Andreas Panag

    (@andrewp-2)

    Please go to wpml.org (https://wpml.org/) and update all the plugins to the latest version manually.

    After that please update WCML to the latest version.

    Try again and inform us for the results.

    Thank you.

    Hello,
    today I’ve updated all WPML plugins to latest versions.
    but still no working.

    Detailed description:

    I’ve updated all plugins to latest versions (manually, following this istructions https://wpml.org/forums/topic/wpml-auto-update-not-working/#post-462904 because I did not have any alert for automatic updates, even checking in “registered” wpml settings, pressing the “check for updates” button)

    After the update, I still have the problem with “weight” attributes.

    In weights tab there’s no weights to translate: http://prntscr.com/7kylm5
    even if I’ve used lot of that on products.
    The only thing I could translate is the plural and singular tag “weight/weight”
    then I pushed the “sync” button. and apparently all product were synced

    Then I tryed to translate the product, but in WCML translation interface, I don’t have any option to translate the weight variations of my products.
    Then only thing I see to translate are:
    – title
    – slug
    – content
    – excerpt
    – images
    – purchase note
    – yoast seo stuff

    look: http://prntscr.com/7kymb3

    I thought, maybe “weights” are not to be translated… but I can’t see variations in frontend.

    infact, even if product in the original language (italian) has variations and is purchasable: http://prntscr.com/7kynl2
    the english translation has no variations, and no add to cart button: http://prntscr.com/7kynvd

    Its been a while I’m stuck on this.
    anyone has figured out how to fix this?

    I have an update

    I noticed that in products->attributes->weights
    all the weights I’ve inserted are not linked to any language, while they should be linked to the original language (italian).

    look: http://prntscr.com/7l4tn5

    Maybe this happens because I’ve inserted all weight variations directly form the products edit screen

    Infact if I add a weight from the weight attributes screen, it gets linked to original language.

    Problem is I already have a lot of products using that variations in original language. How can I link already inserted variations to a language? Editing them do not the trick, even if “italian” is selected as language, they italian term counts remains zero.

    Problem Solved.

    The issue was due to the fact that I changed the attribute name after having created attributes.

    First time I created the attribute type, I called it “Peso” (italian for weight), after having all the products I’ve installed WCML and I saw that my “peso” name was considered by WCML as english native name, and it was asking me for the italian translation (even in WPML I setup Italian to be the original language). So I switched the name of the attribute from italian “peso” to english “weight”.

    This was causing the issue.

    infact, looking at the wp_icl_translations database table, I saw that all translations of my attribute variations had “tax_pa_peso”.

    I Changed directly in database to “tax_pa_weight” and everything now is going fine.

    Maybe some advice “never change attribute names after having saved variations” would be helpful in such a case… I’m not use to worry about taxonomy names in wordpress 😉

    Plugin Author Andreas Panag

    (@andrewp-2)

    Thank you very much for your advice and for finding what was the problem!

    I still have the problem that I can’t save the translation of a taxonomy label.

    When I fill in a translation for the labels and click on OK, nothing happens.

    I use all the new versions of the plugins.

Viewing 15 replies - 1 through 15 (of 24 total)
  • The topic ‘Product Attribute Translations Not Saving’ is closed to new replies.