Support » Plugin: Yoast SEO » “Product Archive – Title” How do i change this?

  • Resolved zhaochi

    (@zhaochi)


    Since i installed Yoast Seo when i share the url of my Woocommerce Store it appears “Products Archive- The Demon Valley ( the name of my shop ) and the description of one product below, i don’t like how it looks, i’ve been trying to quit the “archive” and add the description of the shop instead of the description of the product but i haven´t got success yet.

    i thought that the problem was here:

    Title: %%pt_plural%% Archive %%page%% %%sep%% %%sitename%%

    Meta description: %%excerpt%%

    However i’ve modified it too many different ways and it still looks the same.

    I hope you can help me. Thanks

    The page I need help with: [log in to see the link]

Viewing 10 replies - 1 through 10 (of 10 total)
  • Plugin Support Md Mazedul Islam Khan

    (@mazedulislamkhan)

    You can remove the word “Archive” from the shop page SEO title directly by editing the SEO title from your shop page using the Yoast SEO meta box.

    I am also struggling with this, and I can’t follow the directions above. My site title in the setting just shows “Shop”, but when I go to the page, it shows “Products Archive”. I know this is an issue with Yoast. I’ll uninstall if I need to.

    • This reply was modified 1 year, 3 months ago by grantog.

    The problem is with those tags (e.g. %%pt_plural%%). I had the same problem until I removed all of them (it’s important not to leave ANY) and replaced it with a plain text.

    After doing that everything will be fine.

    @chrisplaneta, where are these tags you speak of? In a certain database file?

    @grantog They are the violet “pills” in the title editing section. They are simply graphical representations of those %%something%% tags.

    thank you thank you thank you @chrisplaneta I was ready to throw something against a wall trying to fix this

    • This reply was modified 1 year, 2 months ago by jennnjennjen. Reason: typo

    Thank you so much @chrisplaneta this solved it for me!! I had NO idea how to solve it and tried everything. Thank you!

    giftsting

    (@giftsting)

    Please view the solution in an easy to follow picture format here Removing “Products Archive” from the title of a WooCommerce-Storefront Website

    Original Compositions by ImpieReal Systems of Gift Sting International

    like so many previous comments, @chrisplaneta offered the first solution that worked for me.

    i am not certain of the initial steps i took to disable ‘Archives’ for the products, categories and tags under the Taxonomies tab… but somehow i did it so that elements like Term Title, Page and Site Title were highlighted in purple but the word Archives in the SEO Title field was was still listed, but not highlighted.

    i mistakenly assumed that this meant it was disabled.

    after reading the thread above, i copied everything in the SEO Title field, pasted it into notetab, deleted the word Archives and pasted the remaining terms back into the SEO Title field.

    that finally fixed it.
    the word Archives is not gone from my title tags.

    thank you @chrisplaneta !

    I want to thank this whole thread and @giftsting and @chrisplaneta for making this so clear… I’ve been wanting to do this for the Tribe Events Calendar and for bbPress but couldn’t figure it out until I found this thread… And lo and behold it was so simple… _/\_

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘“Product Archive – Title” How do i change this?’ is closed to new replies.