Support » Plugin: WooCommerce Stripe Payment Gateway » Processing response can take up to 70 seconds

  • Resolved The Web Warriors

    (@thewebwarriors)


    I’m testing a WooCommerce system with Stripe. When I run a transaction, the “processing response” can take up to 70 seconds – causing a 504 error.

    The order ends up completing successfully but the user gets no feedback because the site times out.

    The Stripe log shows:

    11-19-2017 @ 07:07:03 - Info: Begin processing payment for order 863 for the amount of 37.00
    11-19-2017 @ 07:07:03 - charges request: Array
    (
        [currency] => aud
        [amount] => 3700
        [description] => Kinu Coaching - Order 863
        [capture] => true
        [expand[]] => balance_transaction
        [metadata] => Array
            (
                [Customer Name] => John Hill
                [Customer Email] => xxxxxxx
            )
    
        [source] => xxxxxxx
    )
    
    11-19-2017 @ 07:07:04 - Processing response: stdClass Object
    (
        [id] => xxxx
        [object] => charge
        [amount] => 3700
        [amount_refunded] => 0
        [application] => 
        [application_fee] => 
        [balance_transaction] => stdClass Object
            (
                [id] => xxxxx
                [object] => balance_transaction
                [amount] => 3700
                [available_on] => 1511568000
                [created] => 1511035596
                [currency] => aud
                [description] => Kinu Coaching - Order 863
                [fee] => 136
                [fee_details] => Array
                    (
                        [0] => stdClass Object
                            (
                                [amount] => 12
                                [application] => 
                                [currency] => aud
                                [description] => GST
                                [type] => tax
                            )
    
                        [1] => stdClass Object
                            (
                                [amount] => 124
                                [application] => 
                                [currency] => aud
                                [description] => Stripe processing fees
                                [type] => stripe_fee
                            )
    
                    )
    
                [net] => 3564
                [source] => xxxxx
                [sourced_transfers] => stdClass Object
                    (
                        [object] => list
                        [data] => Array
                            (
                            )
    
                        [has_more] => 
                        [total_count] => 0
                        [url] => /v1/transfers?source_transaction=xxxxxx
                    )
    
                [status] => pending
                [type] => charge
            )
    
        [captured] => 1
        [created] => 1511035596
        [currency] => aud
        [customer] => 
        [description] => Kinu Coaching - Order 863
        [destination] => 
        [dispute] => 
        [failure_code] => 
        [failure_message] => 
        [fraud_details] => stdClass Object
            (
            )
    
        [invoice] => 
        [livemode] => 
        [metadata] => stdClass Object
            (
                [Customer Name] => John Hill
                [Customer Email] => xxxxxxx
            )
    
        [on_behalf_of] => 
        [order] => 
        [outcome] => stdClass Object
            (
                [network_status] => approved_by_network
                [reason] => 
                [risk_level] => normal
                [seller_message] => Payment complete.
                [type] => authorized
            )
    
        [paid] => 1
        [receipt_email] => 
        [receipt_number] => 
        [refunded] => 
        [refunds] => stdClass Object
            (
                [object] => list
                [data] => Array
                    (
                    )
    
                [has_more] => 
                [total_count] => 0
                [url] => /v1/charges/xxxxxxx/refunds
            )
    
        [review] => 
        [shipping] => 
        [source] => stdClass Object
            (
                [id] => xxxxxx
                [object] => card
                [address_city] => Crows Nest
                [address_country] => AU
                [address_line1] => 4/143 Ernest St
                [address_line1_check] => pass
                [address_line2] => 
                [address_state] => NSW
                [address_zip] => 2065
                [address_zip_check] => pass
                [brand] => Visa
                [country] => US
                [customer] => 
                [cvc_check] => pass
                [dynamic_last4] => 
                [exp_month] => 11
                [exp_year] => 2018
                [fingerprint] => kaaQAg7VRzBgc1V3
                [funding] => credit
                [last4] => 4242
                [metadata] => stdClass Object
                    (
                    )
    
                [name] => John Hill
                [tokenization_method] => 
            )
    
        [source_transfer] => 
        [statement_descriptor] => 
        [status] => succeeded
        [transfer_group] => 
    )
    
    11-19-2017 @ 07:08:15 - Success: Stripe charge complete (Charge ID: ch_1BPcaGBP8kUOERQqS8y4MIkF)

    Notice the “Success” is over 1 minute since the “Processing request”

Viewing 3 replies - 1 through 3 (of 3 total)
  • I am having exactly the same issue! Tried switching PHP versions, themes and disabling all plugins except woocommerce and stripe, however, the same issue persists.

    Thread Starter The Web Warriors

    (@thewebwarriors)

    Solved.

    I found out it was the email server that caused the delay. I’m using the Postman SMTP server plugin which had trouble talking to the email server. I updated it so that it uses the Gmail email server instead.

    Plugin Author royho

    (@royho)

    @thewebwarriors – thanks for posting the cause/solution!

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Processing response can take up to 70 seconds’ is closed to new replies.