Support » Plugin: Fast Velocity Minify » Processed JS/CSS Not Serving from Mapped Domain

  • Resolved Mark Tenney

    (@marktenney2)


    I’m trying to set up an ad campaign with Google Ads, and they are claiming that my FVM files are being flagged as malware because they are being served from the wrong domain. My site is built on a multisite installation and uses domain mapping. The FVM files are coming from my subdomain (platform.digitalchurch.website) instead of the final mapped domain (digitalchurchplatform.com).

    I’ve tried setting the mapped domain as the cache URL and also as the CDN URL, and neither seem to be changing the URL that the files are served from. Could you help me fix this? Thank you!

    The page I need help with: [log in to see the link]

Viewing 2 replies - 1 through 2 (of 2 total)
  • Plugin Author Raul P.

    (@alignak)

    Unless the domain itself contains malware and has been blacklisted, or unless some of the js files on your site already contain malware, it should be irrelevant that the fvm files are served from another domain. In fact, it’s completely normal to use a different url for static assets, such as when you add a cdn service.

    Are you sure that they specified that this is the reason?

    Google usually marks some third party ads and tracking codes as malware, regardless of it being malware of not. Several sites are clean and they trigger this, until you can remove those scripts that they don’t like and are actually safe.

    The site passes their safe browsing test:
    https://transparencyreport.google.com/safe-browsing/search?url=https:%2F%2Fdigitalchurchplatform.com%2F

    1)
    That being said, if you wish to use the default domain, all you need to do is to disable all of the CDN settings on FVM and delete the domain name from there.

    2)
    The domain comes from the default site_url function, so make sure that the url is correct on the database.
    https://developer.wordpress.org/reference/functions/site_url/

    You can force the url on wp-config.php if you like:
    define('WP_SITEURL', 'https://digitalchurchplatform.com/');

    3)
    If you are saving the CDN settings and they simply don’t get saved correctly (refresh to check), or show your old domain, that may be because you still have old database fiels saved from FVM 2.

    In that case, please install version 3.0 first (will delete the FVM 2 old settings automatically), purge caches and upgrade again to the latest version.
    https://downloads.wordpress.org/plugin/fast-velocity-minify.3.0.0.zip

    4)
    Finally, if the settings are correct on wp-admin but not on the frontend, please make sure you purge all caches on your server, or whatever cdn you may use.

    If the CDN options are deselected and the domain is empty, and if you already purged FVM followed by any other cache on the site/server/cdn, it cannot be showing the domain on the frontend.

    If that happens, contact your hosting as the page cache is still not cleared, and that is why you are still seeing it pointing to the old urls.

    Thread Starter Mark Tenney

    (@marktenney2)

    Thank you Raul!

    I just needed to set the site url field. It makes sense that the plugin wouldn’t use relative urls by default, since it needs to be able to write CDN urls as needed. I should’ve thought about that site URL field.

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Processed JS/CSS Not Serving from Mapped Domain’ is closed to new replies.