Support » Plugin: RFQ-ToolKit for WooCommerce » Proceed To Checkout always showing

  • The ‘Proceed To Submit Your RFQ’ button won’t show up on my cart page. Whatever I do I just get the ‘Proceed To Checkout’ button with cart totals.

    I tried uninstalling/reinstalling and that didn’t fix it, and I don’t have any template overrides in place.

    Thanks

Viewing 11 replies - 1 through 11 (of 11 total)
  • Plugin Author Neah Plugins

    (@gplsaver)

    Sriom,
    What is the checkout option in Woo-RFQ setting? Normal or RFQ

    Also any of these checked ?

    1- Always Show Prices With RFQ Chekout

    2- Show Prices with normal Checkout?

    We are working on better documentation 🙂

    • This reply was modified 1 year, 6 months ago by  Neah Plugins.
    Plugin Author Neah Plugins

    (@gplsaver)

    Sriom,

    Disregard my last reply. I found the problem and it has been fixed in 1.7.3. 1.7 has been a major update and we missed this one.

    Thanks for looking at it.

    Another thing I noticed after my initial post was that prices were always showing up on the product page, regardless of settings.

    Plugin Author Neah Plugins

    (@gplsaver)

    Sriom,
    OK maybe we should look at the settings:
    What is the checkout option in Woo-RFQ setting? Normal or RFQ

    Also any of these checked ?

    1- Always Show Prices With RFQ Chekout

    2- Show Prices with normal Checkout?

    Ok, here’s some more info:-

    I have a live version and a dev version of the site. The live version has been rolled back to Woo-RFQ 1.6.7, the dev version is 1.7.3

    Both versions have the same Woo-RFQ settings. Checkout Option is set to RFQ, and the only other setting that is checked is ‘Show Link To RFQ Cart in the single product description’

    Here’s the source HTML for the ‘cart_totals’ div on the cart page in version 1.7.3

    <div class=”cart_totals “>
    <h2>Cart Totals</h2>
    <table cellspacing=”0″ class=”shop_table shop_table_responsive”>
    <tbody><tr class=”cart-subtotal”>
    <th>Subtotal</th>
    <td data-title=”Subtotal”></td>
    </tr>
    <tr class=”order-total”>
    <th>Total</th>
    <td data-title=”Total”></td>
    </tr>
    </tbody></table>
    <div class=”wc-proceed-to-checkout”>
    Send the RFQ
    </div>
    </div>

    And here’s the same div in version 1.6.7:-

    <div class=”cart_totals “>
    <table cellspacing=”0″>
    <tbody>
    <tr class=”order-total”>
    <td></td>
    </tr>
    </tbody>
    </table>
    <div class=”wc-proceed-to-checkout”>
    Send the RFQ
    </div>
    </div>

    Here’s the source HTML for the itemprop=”offers” div on the product page in version 1.7.3:-

    <div itemprop=”offers” itemscope=”” itemtype=”http://schema.org/Offer”>
    <p class=”price”>0</p>
    <meta itemprop=”price” content=”0″>
    <meta itemprop=”priceCurrency” content=”GBP”>
    <link itemprop=”availability” href=”http://schema.org/InStock”>
    </div>

    Here’s the same div in version 1.6.7

    <div itemprop=”offers” itemscope=”” itemtype=”http://schema.org/Offer”>
    <link itemprop=”availability” href=”http://schema.org/InStock”>
    </div>

    Also, prices on the single product page are showing up as 0 in version 1.7.3 if ‘Always Show Prices With RFQ Checkout’ is unchecked. If ‘Always Show Prices With RFQ Checkout’ is checked prices are shown correctly.

    Hope that helps.

    Plugin Author Neah Plugins

    (@gplsaver)

    Thanks for the info,
    Do the prices show in the cart page as well or just the products page. I get that it is only showing 0 in the single product page.

    Plugin Author Neah Plugins

    (@gplsaver)

    I just uploaded 1.7.4. In addition to another issue, I know it should fix the zero in the single product page. I am hoping it is fixing the product page but please let me know. as far as i know i and a few others are not getting the products page error but we did have a problem on cart(in the normal checkout) and zero on the single product.

    • This reply was modified 1 year, 6 months ago by  Neah Plugins.

    There wasn’t a problem with prices showing up on the products page, it was just on the single product page. 1.7.4 has fixed the price problem, but the cart totals table is still showing up on the cart page.

    Plugin Author Neah Plugins

    (@gplsaver)

    Please try 1.7.5 and see if it fixes the issue

    Ok, 1.7.7 fixed the last issue but introduced a new one.

    I use the Save and Share Cart plugin (https://codecanyon.net/item/save-share-cart-for-woocommerce/5568059) which injects the following as the first element in <div class=”cart-collaterals”>:-

    <div class=”cxecrt-button-holder”>
    Save & Share Cart
    </div>

    This code is now being removed by Woo-RFQ.

    Also, in debug mode there’s an undefined variable error:-

    Notice: Undefined variable: rfq_enable in /wp-content/plugins/woo-rfq-for-woocommerce/includes/classes/gpls_woo_rfq_functions.php on line 125

    • This reply was modified 1 year, 6 months ago by  Sriom. Reason: Changed 1.7.5 to 1.7.7 in first line
    Plugin Author Neah Plugins

    (@gplsaver)

    Ok. Hopefully , I think 1.7.8 second update as of the date of this post, should fix the issue.
    The main reason for removing templates was to improve compatibility with different themes. previous version used to override cart which was causing trouble for people who overrode their cart in their themes.

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘Proceed To Checkout always showing’ is closed to new replies.