WordPress.org

Support

Support » Plugins and Hacks » Hacks » Problems with wp_redirect

Problems with wp_redirect

  • I have made plugin which uses wp_redirect after it has processed form. It works well on my own computer (WAMP) and on my other linux-based dev server, but on my production server redirect doesn’t work and I get message saying “Warning: Cannot modify header information – headers already sent…” but I’m sure I have output nothing before redirect and It does work on my other 2 servers so…

    Any tips how to find out what causes this? Any settings that might do it?

    I use same thems/plugins combo on my WAMP and production server. I also tried to set my plugin to first one which handles content by adding priority 1 to add_filter command.

    I tried using both headway theme and basic twentyten theme but error still happened so I think its not theme related. Error message doesn’t help either because it only points to themes header functions.

Viewing 1 replies (of 1 total)
  • Sorted it out with ob_start at beginning of file, just in case, but still wondering why it was working on 2 servers and not in one…

Viewing 1 replies (of 1 total)
  • The topic ‘Problems with wp_redirect’ is closed to new replies.
Skip to toolbar