Support » How-To and Troubleshooting » Problems with wp_get_archives and wp_tag_cloud

Problems with wp_get_archives and wp_tag_cloud

  • Hi everybody,

    This is probably a very dumb question, but I’m at a loss for what to do. I use wp_get_archives and wp_tag_cloud on my blog’s sidebar, only when you click on any of those links you’re immediately punted to my Main Index template.

    The Main Index template isn’t set up to show posts, it’s just a header, footer, and static content between. Is there a way to bypass the Main Index template when showing results from wp_get_archives or wp_tag_cloud? Maybe assign them both their own special template?


Viewing 3 replies - 1 through 3 (of 3 total)
  • Moderator Michael


    Forum Moderator

    review http://codex.wordpress.org/Template_Hierarchy

    i.e. if your index.php is customized to show the static content, and your theme does not have archive.php and tag.php, then you might get the problem you are describing.

    Yes! That was totally the issue. I knew it was something dumb and simple like this, but whenever I searched the Codex I just kept getting the Archive Page entry.

    Thank you!

    You can direct posts to specific templates like this:

    <?php include (TEMPLATEPATH . '/your-archive-template.php'); get_header()?>

    in your case it would go in place of get_header in your main index.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Problems with wp_get_archives and wp_tag_cloud’ is closed to new replies.