Support » Plugin: WP Super Cache » Problems with WP Super Cache

  • Azhar Nadeem


    Dear Sir…
    I am trying to add a caching plugin to my website which is using WordPress 3.9.1, Jarida WordPress Theme and Godaddy shared hosting. However, I remain stumped as my website goes blank as soon as I activate WP-Super Cache….A little search on google revealed that many people are facing the same problem and they ended up uninstalling the plugin.
    I have inatalled,uninstalled and re-installed the plugin but the problem refused to budge. I am not ready to give up, so need very personal support to resolve this….My URL is

    Kindly help..

    Azhar Nadeem…

Viewing 11 replies - 1 through 11 (of 11 total)
  • Richard Archambault


    Happiness Engineer


    If your site goes blank, there may be something in your PHP error logs that can help determine the reason. Have a look for any errors in the log for around the time when you activate WP Super Cache, and let me know what you find.

    Azhar Nadeem


    Dear Sir
    As per instructions, I activated WP Super Cache to fetch the error logs. This is what happened.
    1. Site goes blank as soon as WP Super Cache is activated.
    2. Three error files appeared in Error logs but without any text
    3. Admin Panel of website also went blank and I was not even able to deactivate the plugin
    4. I deleted WP-cache-config.php and things started moving. This allowed me to deactivate the plugin.
    5. After deleting WP=cache-config.php file, below text appeared in one of error log files.

    [Sat Aug 02 01:03:12 2014] [10776786] [fcgid:warn] (104)Connection reset by peer: [client] mod_fcgid: error reading data from FastCGI server, referer
    [Sat Aug 02 01:03:12 2014] [10776786] [core:error] [client] End of script output before headers: wp-comments-post.php, referer

    Kindly advise further.



    How to Solve WP Super Cache Problem?
    1. Deactivate the WP Super Cache
    2. In your server control panel, edit the wp-config.php file
    3. Under the MySQL settings of your wp-config.php file, comment or remove this line of codes:


    define(‘WP_CACHE’, true); //Added by WP-Cache Manager
    define( ‘WPCACHEHOME’, ‘/home/test/public_html/wp-content/plugins/wp-super-cache/’ ); //Added by WP-Cache Manager


    //define(‘WP_CACHE’, true); //Added by WP-Cache Manager
    //define( ‘WPCACHEHOME’, ‘/home/test/public_html/wp-content/plugins/wp-super-cache/’ ); //Added by WP-Cache Manager

    And this will resolve the issue..

    @richard Archambault
    Dear Sir
    Wp-super cache is something very wonderful..It has given me the speed which which I looked for but also gave me something which I really dont want.
    WP-super cache is causing White of Screen of death (WSOD) intermittently. I searched for this problem and in one of the threads, plugin authors suggested that it may be due to PHP_memory, so I enhanced memory to 256M. Problem reduced but not resolved.below is link to error log page while debugging

    Richard Archambault


    Happiness Engineer

    Hi Azhar,

    256MB is generally much more that what a WordPress site needs to run, so I suspect that the problem is elsehwere on your site; maybe your theme or one of your plugins uses inefficient queries. In any case, I see that you are now using the W3 Total Cache plugin. Are you still seeing the WSOD? Did you check your site’s error logs for the times when the WSOD appears?

    Hi Richard
    Thanks for your response. Yes i am currently using W3TC but I really don’t want to prefer it over WP-Super Cache. I really tried hard to get WPSC running for me as it gives amazing speed.
    Latest situation is..
    1. WSOD only appears after activating Super Cache. I tried to switch off all other plugins as well as switching theme to default but nothing worked.
    2. Updated PHP memory but that did not help either.
    3. I did not check error logs when WSOD appearing but I dis contact Godaddy Support to inquire if some server error is causing this problem and support guy said that nothing is wrong at server end.

    WSOD was creating a bad user experience so had no choice but to revert to W3TC. However, I am still looking forward to get the super-cache resolved for me and revert to my favorite caching solution.

    Hope you can help in this regard.

    Richard Archambault


    Happiness Engineer

    Hey Azhar,

    a WSOD should normally leave some trace in the error logs. As I mentioned, 256MB is a lot, but the error logs would really help in pinning this down. Without that, we’re flying blind.

    me same, but in my occasion, the WSOD appear only sometime. Try it on
    If i deactivate plugin WSOD disappear

    hi gents!
    for those whoever uses GoDaddy hosting
    I’m quite sure you have good half of PHP features disabled

    I dont use godaddy hosting. Only domain. I try if is it problem with cloudflare but not.

    after some attempts, wonder, tat problem is with php cache. If i change it to legacy, everything is perfect

    Hi Richard Archambault
    I reinstalled Super Cache because its really difficult to walk away from this Super plugin so easily. However, some new kind of errors like
    1. Bad file descriptor:
    2. AH01276: Cannot serve directory /var/chroot/home/content/

    Please find link to error log files and help me unlock the potential of your amazing product.

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘Problems with WP Super Cache’ is closed to new replies.