Support » Fixing WordPress » Problems with WordPress 2.1…writing a new post

  • I upgraded to 2.1 just the other day…now I can’t post to my site because the write post feature, won’t publish when I hit publish. It either says “STACK OVERFLOW at LINE 500″ or it says ” Are you Sure you Want to Navigate Away from this page? The changes you made will be lost if you navigate away from this page. Press ok to continue or Cancel to Stay on this page”

    I know this is a new version…but I would think this shouldn’t happen?

    I’ve tried on Mac 10.4 (both Firefox & Safari), on PC (Both Firefox & Internet Explorer 6)..

    Can someone help???


Viewing 9 replies - 1 through 9 (of 9 total)
  • I am having similar issues. I do not get the stack overflow error but I do get the “are you sure you want to navigate away from this page?” question. If I cancel it takes me back to my post. If I continue it saves or publishes the title of the post but not the post itself.

    Here is what I find so far. On my MAC (10.4.8) if I use Safari the post will save/publish with no error so I am assuming things are fine at the host server level. The only strange thing I get with Safari is that my WP-Amazon plug in will not work unless I save the post and then edit it. On a new post the “insert from Amazon” option is not available. However, When I use Firefox or Camino I get the “are you sure you want to move away from this page” message.

    On my PC I get similar results. Things work in IE but not in Firefox.

    Since it works in safari(MAC) and IE(windows) I assume that the problem is not with WordPress 2.1 but with Firefox. I have cleared cache and that helped bring back the editor toolbar buttons but I still cannot save a post in Firefox.

    Anyone have any ideas what could be causing this only in Firefox? I had no problems with WP 2.0.7. The only change has been the upgrade to 2.1.


    On my Linux (Suse 10) computer the only browser I have installed is Firefox and I cannot save/publish new posts. I get the message that says “are you sure you want to navigate away from this page? all information will be lost…”

    If I click continue then my the entry will save/publish with only the title. The contents of the post itself are gone. So if I choose publish I get a title on my blog but no content in the post. This seems to be only firefox browsers for me regardless of the OS I am in.

    If I use IE on a PC or Safari on a MAC things work ok. I will try to find out what is different in Firefox with 2.1 and 2.0.7 and post what I find out. If anyone else has ideas I would love to hear them.

    Thanks again.

    I am having similar problems of a different nature.

    Clearing the cache in Firefox brought up my buttons, but I can’t switch to the ‘code’ tab when writing. I’m not getting any error messages in Firefox, but posting only saves the titles, not the content of the posts.

    Rendering in IE brings up some debugging prompts, while attempting to post in real IE won’t let me click in the post field at all. Again, I can enter a title.

    Checking a different post, I tried turning off the visual editor.

    That seems to have done the trick for now. I’d like to use the visual editor, though. Any thoughts?


    I had the exact same problem, and it turned out to be a conflict with the theme I was using (Lowstream). You can check out the thread I had going here:

    Basically, since the theme used prototype.js, and WordPress 2.1 used prototype.js, there were some issues. The folks at Lowstream gave me a fix ( you can check it out via the post above), but basically, it’s:


    For those that are more technically inclined, I’ve discovered the cause of the issue and have corrected it internally. The jist is that the new modifications to the WordPress WYSIWIG editor use a Javascript file named prototype.js. Anyone who’s ever looked around in Lowstream’s assets would know that Lowstream uses a file by the same name, but with different code. I order to make the Lowstream header gallery function properly, Lowstream’s Javascript needs to be injected into the WordPress ACP header every time any of it’s functions load (it’s not the best solution, but the WordPress devs don’t make things very easy). In this case, since both files have the same name, Lowstream’s prototype.js was overriding the one used by WordPress and since there’s a difference in code, we got errors.

    All in all, this has been corrected internally and will be rolled into the 2.2.4 release.

    But, for those that are looking for an immediate solution; I can tell you how to go about changing Lowstream so that this issue no longer occurs. You’ll need the following:

    * FTP access to your website.
    * A good text editor.
    * Some very basic knowledge of how to get around in PHP files.

    1. Okay. First things first. Go to your Lowstream folder and open the file functions.php in your text editor.
    2. Find the line 34, which contains a call for prototype.js.
    3. Replace prototype.js with pt.js (this is what I’m using internally at the moment).
    4. Save the file and upload it.
    5. Now, go into your lowstream/js folder on your webserver and rename prototype.js to pt.js and then save it.
    6. You’re done.


    To get mine to work properly, I also had to go into pt.js and do a search and replace – “Prototype” to “Pt” and “prototype” to “pt”. Not sure if the initial caps were necessary, but the WYSIWIG works like a champ now.

    Good luck,

    Thanks Chuck. That certainly gave me some new ideas to look at. I appreciate that.

    I tested the default themes and I get the same results. I wish I knew what changed in how firefox processes the new-post page in 2.1 differently than it did in 2.0.7. For now I can function by limiting my writing new posts to my MAC and using Safari because that works fine. But if anyone has any ideas on where to look in Firefox to resolve this I would appreciate it. Thanks

    I had the same problem I gt so frustrated with this version cause it kept giving me the error :

    “STACK OVERFLOW at LINE 500″ or it says ” Are you Sure you Want to Navigate Away from this page? The changes you made will be lost if you navigate away from this page. Press ok to continue or Cancel to Stay on this page”

    I did what standsalone said.. and it works now.. turn off the visual editor for now…



    i found the problem (at least for me). I had installed a plugin ‘yet another photoblog’. there is some conflict with using that plugin. i de activated that. it works.


    Hi. Has anyone using this theme upgraded to 2.3.1? Post content does not seem to save or display for new posts after the upgrade.

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Problems with WordPress 2.1…writing a new post’ is closed to new replies.