Support » Plugin: Autoptimize » Problems with WooCommerce Emails

  • With Autoptimize enabled, Woocommerce Emails look like this.

    looks like the opening and closing tags <, > are being removed from the html

    !DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd"
    html xmlns="http://www.w3.org/1999/xhtml" lang="en-US" style="width: 100% !important; min-width: 100%; margin: 0; padding: 0; -webkit-text-size-adjust: 100%; -ms-text-size-adjust: 100%; background-color: #f2f2f2;"
    head
    meta http-equiv="Content-Type" content="text/html; charset=UTF-8"
    meta name="viewport" content="width=device-width, initial-scale=1.0,
    shrink-to-fit=no"
    !--[if !mso]!--meta http-equiv="X-UA-Compatible" content="IE=edge"
    !--![endif]--titleFaadu/title
    /head
    body leftmargin="0" marginwidth="0" topmargin="0" marginheight="0" offset="0" style="width: 100% !important; min-width: 100%; margin: 0; padding: 0; -webkit-text-size-adjust: 100%; -ms-text-size-adjust: 100%; background-color: #f2f2f2;"
    table role="presentation" class="email_table" width="100%" border="0" cellspacing="0" cellpadding="0" style="box-sizing: border-box; mso-table-lspace: 0pt; mso-table-rspace: 0pt; border-spacing: 0; width: 100%; min-width: 0 !important;"tbodytr
    td class="email_body email_start email_end tc" style="box-sizing: border-box; mso-table-lspace: 0pt; mso-table-rspace: 0pt; vertical-align: top; font-size: 0 !important; line-height: 100%; padding-left: 8px; padding-right: 8px; padding-top: 32px; padding-bottom: 32px; background-color: #f2f2f2; text-align: center;"
    !--[if (mso)|(IE)]table role="presentation" width="640"
    border="0" cellspacing="0" cellpadding="0" align="center"
    style="vertical-align:top;width:640px;Margin:0 auto;"tbodytrtd
    style="line-height:0px;font-size:0px;mso-line-height-rule:exactly;"![endif]--
    table role="presentation" class="content_section" width="100%" border="0" cellspacing="0" cellpadding="0" style="box-sizing: border-box; mso-table-lspace: 0pt; mso-table-rspace: 0pt; border-spacing: 0; width: 100%; min-width: 0 !important; max-width: 640px; margin: 0 auto; text-align: center;"tbody
    tr
    td class="content_cell hero_b pb brt tc" background="https://faadu.in/wp-content/themes/faadu/woocommerce/emails/images/hero_background.png" style="box-sizing: border-box; mso-table-lspace: 0pt; mso-table-rspace: 0pt; vertical-align: top; font-size: 0 !important; line-height: inherit; padding-left: 8px; padding-right: 8px; background-color: #ff005e; background-repeat: no-repeat; background-position: top center; border-radius: 4px 4px 0 0; text-align: center; padding-bottom: 16px;"
    table role="presentation" class="column" width="100%" border="0" cellspacing="0" cellpadding="0" style="box-sizing: border-box; mso-table-lspace: 0pt; mso-table-rspace: 0pt; border-spacing: 0; width: 100%; min-width: 0 !important;"tbody
    tr
    td class="column_cell sc logo_c pt tc" style="box-sizing: border-box; mso-table-lspace: 0pt; mso-table-rspace: 0pt; vertical-align: top; padding-left: 8px; padding-right: 8px; font-family: Arial, Helvetica, sans-serif; font-size: 16px; color: #ffffff; text-align: center; padding-top: 16px; line-height: 100%;"
    /td
    /tr
    • This topic was modified 3 years, 11 months ago by Abhi.
    • This topic was modified 3 years, 11 months ago by Jan Dembowski.
Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author Optimizing Matters

    (@optimizingmatters)

    weird … is this woocommerce native, or are you using a plugin to generate those mails?

    can you test what option specifically is triggering this by disabling only CSS or JS or HTML optimization?

    Thread Starter Abhi

    (@abhi9)

    Thanks for your reply!

    Woocommerce native emails. It happens with 1 out of 3-4 emails. Tried disabling all plugins, so I’m pretty sure Autoptimize is doing it.

    Also, Aggregate inline CSS option does it.

    Plugin Author Optimizing Matters

    (@optimizingmatters)

    It happens with 1 out of 3-4 emails

    so it’s not consistent? weird.

    Also, Aggregate inline CSS option does it.

    so all is OK if “aggregate inline CSS” is off?

    could you upload the HTML of a broken and of an OK mail on https://gist.github.com or https://pastebin.com or mail them to me as attachements to futtta-at-gmail-dot-com?

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Problems with WooCommerce Emails’ is closed to new replies.