Support » How-To and Troubleshooting » Problems with Visual Editor in WP 3.1

Problems with Visual Editor in WP 3.1

  • I’ve just installed version 3.1 and blog is looking good generally except the visual editor is no longer functioning properly.

    There are no buttons at the top of the text box, the text is set to be white, so you can only see it when you highlight or switch to the HTML view. Also when you do switch from HTML back to visual, the html tags are still visible.

    Anyone resolved this?

    I have de-activated my plugins hoping that this would resolve – it did not. I have checked the active_plugin row within the db and that was zero so it had registered the deactivation correctly.

    Any ideas out there please?

Viewing 15 replies - 31 through 45 (of 90 total)
  • BTW – For me, on a mac, doesn’t matter what browser I use. None of the other options posted on this thread worked either.

    Very surprised that WordPress released this with a bug of this kind in it. I would definitely not suggest folks update until this is all worked out.

    Just checked – No issues on a Mac for me, using Safari.

    Actually, my initial upgrade WAS manual. I upgraded the site from a much earlier version of WP.

    endgamepr – Can you DELETE wp-admin forcefully and then upgrade manually?

    Also try the TwentyTen theme. Some themes goober things.

    I tried Twenty Ten – no joy for me alas.

    I deleted and replaced wp-admin – again no joy.

    In fact I’ve tried everything on this thread.

    I shall have a go on Chrome. I’m using IE8 right now and its working fine.

    If you’re using FF, try FF 4.

    I know, I know.

    Same problem on my blog too. Can use html but visual editor is not working. Must be a release bug.

    holeytonal – Did you try any of the suggestions?

    Did you manually upgrade, did you try another browser, did you try a new theme, did you try no-plugins?

    I’ve witnessed the same problem and tried everything suggested without any results. It’s only happening in FF and Chrome. IE is okay and I haven’t tried in Safari.

    In order to work around it, I installed the CKEditor plugin so I have some sort of visual editor in place until it gets resolved. This however won’t work if you are using Magic Fields and there are any write panels with multiline textboxes.

    RonnieSan – GREAT TIP! Thank you. That plugin is what I have in place in the meantime while they work out the bug.

    This is a serious problem for my clients who can’t code HTML (90% of ’em). I’ve used the same workaround.. for now. Might still need to roll back to the last version. Hope this gets addressed ASAP!!

    Yup Quoindesign – it is quite amazing that this went out like it did. But than again, its FREE! hah

    Same problem here.

    Solved deactivating vipers-video-quicktags plugIn.

    I just fixed the problem. For some reason my php version had reverted back to php 4 I just changed it to php 5 and it brought back all the functionality of the visual editor.

    Hope this helps.

    I’m running php 5.29 and still have the problem.

    Across all of my browsers.

    Its only in WordPress 3.1 for me. I have other sites on earler versions including 3.0xx and they are perfectly fine.


    I am having the same problem too, what is strange for me tho is I have a couple of test blogs running in my domain and they are working absolutely fine!!! very strange I originally uploaded manually through filezilla, the only difference is a uploaded from two different computers so Iv had to download a couple of versions of 3.1 could possibly the first wp files that I had dowloaded and used for my main install been corrupt ??

    hope this makes sense!!!

    any help would be much appreciated


    Try adding this to the wp-config.php:
    define('CONCATENATE_SCRIPTS', false);
    before this line: require_once.
    It seems to have worked for me, even if it does make the backend a bit slower.

Viewing 15 replies - 31 through 45 (of 90 total)
  • The topic ‘Problems with Visual Editor in WP 3.1’ is closed to new replies.