WordPress.org

Support

Support » Plugins and Hacks » Problems with "umlaute" in the image filename

Problems with "umlaute" in the image filename

  • film3macher
    Member

    @film3macher

    Hi Alex Rabe,

    first I wanna thank you for your brilliant wordpress gallery. But I have a little problem with it. If the image has an umlaut in the filename, the gallery change it into weird characters so the image won’t show in the gallery. I wrote a small funtion what changes umlaute into “normal” characters, but I don’t know where I should but it in. Can you or anyone help me?

Viewing 4 replies - 1 through 4 (of 4 total)
  • Kathryn
    Automattic Happiness Engineer

    @zoonini

    You should never have accented characters or special characters of any kind (i.e. ampersands or asterisks) in any filenames of images or other files uploaded to the web. This isn’t specific to any plug-in but a web-wide recommendation.

    To be safe, only use letters, numbers, hyphens, underscores or periods in file names.

    film3macher
    Member

    @film3macher

    I know, I know. But I’m programming this page for an friend and he has over 400 pictures with a lot of umlaute in the filenames. So I thought I’m going to make it easier for him and pimp up the plugin. I just need to know where exactly I have to put in my mini tiny function. That’s all. If I’m going to name a page in WordPress with an umlaut in it, wordpress changes it automatically. And I think this would be cool for the plugin too. Humans are stupid, they make mistakes, so we have to make our programming better instead of telling everyone what they allowed to do and what not.

    Kathryn
    Automattic Happiness Engineer

    @zoonini

    I see! I hope someone can help. 🙂

    lombrano
    Member

    @lombrano

    Hello, I’ve got the same problem. Did you find a solution ?
    Thanks a lot

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Problems with "umlaute" in the image filename’ is closed to new replies.