WordPress.org

Forums

[resolved] Problems with theme in Firefox (9 posts)

  1. jbird
    Member
    Posted 10 years ago #

    Hi, I am wondering if anyone has any solutions for me on an issue I'm having with my template in Firefox. Here's an example of what's happening on pages where the sidebar content is longer than the main content:
    http://kimandjason.com/blog/index.php?cat=2

    Everything is fine on the main page, and it works well in Safari and IE on a PC (or so I'm told) I'm guessing it's a CSS issue, but I'm not well-versed enough to know how to fix it...although I can be taught.

    Thanks!

  2. Kafkaesqui

    Posted 10 years ago #

    And the problem that you're seeing is... ? Have you fixed it? If not, please describe the problem we're supposed to find.

  3. jbird
    Member
    Posted 10 years ago #

    There is a large field of black under the main content area, although the side bar is fine. Take a look at the home page to see the difference:
    http://kimandjason.com/blog
    vs.
    http://kimandjason.com/blog/index.php?cat=2

    In Safari, the entire content area is white all the way down to the footer, which is black. But in Firefox, the white stops midway down the page and the sidebar continues all the way to the footer. I don't know how else to explain it, but if you don't see the large fied of black, then apparently the browser and platform you're viewing it on is fine...I'm having the problems with Firefox 1.0.4 on Mac OS 10.3

  4. Joshua Sigar
    Member
    Posted 10 years ago #

    The only thing that stop mid-way is the border between content and sidebar. Everything else...white, on Win XP Firefox 1.0.4

  5. jbird
    Member
    Posted 10 years ago #

    Anyone here running a Mac that sees the problem? (I'm happy to hear that it's looking decent on Windows, though) Thanks!

  6. RosieMBanks
    Member
    Posted 10 years ago #

    In Safari it looks fine.

    In Firefox, you've got a problem with the bottom of the page.

    In Explorer, it's really nuts with the header and at the bottom of the page.

    You can check your theme at these sites:

    http://browsercam.com/ BrowserCam is commercial, but you can register for a free 24 hour period.

    To check only Safari and MacIE: http://www.danvine.com/icapture/

    To check every version of IE: http://www.danvine.com/iecapture/

    Although the last time I looked at danvine.com, the site was down.

  7. moshu
    Member
    Posted 10 years ago #

    @jbird,
    You were happy too early...
    On Win98 FF 1.0.4 the bottom looks exactly as in the pictures linked above by RosieMBanks.

    You may want to check the validation of your site, and clean it up, after that would be easier to find a solution.

  8. jbird
    Member
    Posted 10 years ago #

    I see that you guys are seeing what my problem is. I appreciate the links you all provided. Unfortunately, I'm not an expert at coding, so most of it is greek to me. (I know just enough to make me feel like I know what I'm doing until something like this comes around) I have done some searching, and my design is based on the Benevolence theme:

    http://www.thoughtmechanics.com/blog/2005/01/03/benevolence/

    It appears that others are having similar problems, but no solution has been found. Not sure what to do now, expect maybe try and tinker with a whole new theme...

  9. jbird
    Member
    Posted 10 years ago #

    Well, I gave up and decided to re-format a new theme. Thanks to everyone who helped out.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.