Support » Plugin: Insert Pages » Problems with text encoding

  • Resolved andymiller

    (@andymiller)


    Hi

    I’m having some issues with text encoding.

    The collation on my wp_posts database was set to latin_swedish instead of utf-8. I’ve now set the collation to utf-8 and replaced problem characters with html character entities. The strange thing is that non-English characters in inserted pages are still displaying incorrectly, even though the issue is fixed in the page to be inserted.

    Any advice on how I can fix this? Delete and then reinstall the plugin?

    Thanks.

    (Thanks for all your work on a great plugin).

    • This topic was modified 2 years, 4 months ago by Jan Dembowski.

    The page I need help with: [log in to see the link]

Viewing 8 replies - 1 through 8 (of 8 total)
  • When you change the encoding/collation for the database, this will impact every new table that you create in the database (as long as you create it with the default setting), but your existing tables won’t change just like that.

    See, for example, https://stackoverflow.com/questions/1294117/how-to-change-collation-of-database-table-column

    Thread Starter andymiller

    (@andymiller)

    Thanks. Yes I have indeed changed the collation table-by-table.

    The puzzle I have is why the inserted page displays fine when viewed stand-alone, but doesn’t when it is inserted into another page.

    Thread Starter andymiller

    (@andymiller)

    I’ve temporarily ‘fixed’ the page above by copying and pasting the inserted page into the receiving page.

    Plugin Author Paul Ryan

    (@figureone)

    Hm, interesting. Can you first try to go to Settings > Insert Pages in the WordPress Dashboard and change the Insert method to the other option? Let me know if that makes a difference.

    If you’re still seeing problems, can you provide more info:

    * Your examples linked above seem fine now, can you provide another example, or a specific character (or html entity code) that renders okay on its own page, but not on an inserted page?

    * The current collation of the wp_posts table

    * What the site language is set to (Settings > General > Site Language)

    * Any multilingual plugins you might be using (like WPML)

    Thanks!

    Thread Starter andymiller

    (@andymiller)

    – & #8212; (em dash — )
    – & #039; (apostrophe)
    – & #252; (u with an umlaut ü)
    – & #246; (o with an umlaut ö)
    – & #233; (e with an acute accent é)

    (Spaces inserted into html entities after the ampersand).

    • This reply was modified 2 years, 11 months ago by andymiller.
    Plugin Author Paul Ryan

    (@figureone)

    Interestingly, when I view your sample pages, everything looks fine in all cases (all special characters, including emdashes and apostrophes, show up properly).

    This makes me think it might be a browser character encoding issue. Can you confirm your browser is using UTF-8 when loading each page?

    Thread Starter andymiller

    (@andymiller)

    Hi Paul

    I’m sorry about the delay in getting back to you.

    This is so weird – the pages look fine to me as well now. Hopefully, that means the problem has gone away.

    I didn’t imagine it, honest!

    I’ll mark this as resolved. Thanks for your time and for your work on the plugin.

    Plugin Author Paul Ryan

    (@figureone)

    Awesome, thanks! Let us know if you see it happening again.

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Problems with text encoding’ is closed to new replies.