• Resolved Pandasonic2

    (@pandasonic2)


    I've discovered this plugin and I've chosen it for the new version of my website in substitution of perfmatters.
    Whit freesoul, instead to  deactivate script or css, I can deactivate the entire plugin in the part of the site where is not necessary.
    But I've some problems with tags. While I've about 14 categories I've hundreds of tags and, when I try to save the settings for tags I can't, probably due to a timeout.
    I also tried to flag the checkbox "ALL TAG (BETA)" but doesn't work. How can I solve?
Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Author Jose

    (@giuse)

    Hi @pandasonic2

    Do you have this problem only when you save the tags, or also with other settings?

    Can you please enable the debug by adding these lines in wp-config.php before the comment /* That’s all, stop editing! Happy publishing. */?:

    define( 'WP_DEBUG', true );
    define( 'WP_DEBUG_LOG', true );
    define( 'WP_DEBUG_DISPLAY', false );

    Then please, try again to save the tags, and let me know what you find in wp-content/debug.log.

    After giving me the information I suggest you to disable the debug by removing the lines above or setting WP_DEBUG to false.

    Have a great day!

    Jose

    Thread Starter Pandasonic2

    (@pandasonic2)

    Thank you for the answer. No error (debug was already active). The question is simply: since tags are some hundreds it can’t correctly update the DB. Would be necessary to split tags with some filter, for example the first letter. So the user can update “A” tags, “B” tags and so on…

    Plugin Author Jose

    (@giuse)

    Hi @pandasonic2

    ok, clear.

    Can you please try v. 1.9.3.8.beta-1? You will be able to filter by the first letter of the archive name in Terms Archives.
    You will find it here: https://downloads.wordpress.org/plugin/freesoul-deactivate-plugins.1.9.3.8.beta-1.zip

    The only difference with the official version is the filter, so I would say you can try it also on a live site.

    However, if you have so many tags, you may have another problem, which is the size of the option needed to retrieve settings of the tags.

    If you have a staging environment, I suggest you write this in wp-config.php before the comment /* That’s all, stop editing! Happy publishing. */

    define( 'FDP_SKIP_DB_FOR_ARCHIVES',true );

    In future versions, FDP will provide an option to decide if you want to save the Terms Archives settings in the database or in the filesystem. Until then you need to add that line of code in wp-config.php.

    If you have a lot of archives better you save those options in the filesystem and bypass the database. So, you don’t risk the size of the option increasing too much. On the frontend retrieving those settings from the filesystem will be a lot better in terms of performance when you have many tags, because once FDP detects the URL it will read a very little file related to that URL. The settings will not be saved in a single big file, but in multiple very little files.
    If you have already saved many settings, and you see that you have no issues after bypassing the database, I suggest you delete the option “eos_dp_archives”. This will be managed by FDP in the future, but at the moment you need to do it manually in phpMyAdmin. The data will be taken from the filesystem if you define FDP_SKIP_DB_FOR_ARCHIVES and set it to true, and you will not need anymore that option in the database.

    I hope it helps. If something is not clear let me know.

    Have a great day!

    Jose

    • This reply was modified 1 year, 6 months ago by Jose.
    • This reply was modified 1 year, 6 months ago by Jose.
    Thread Starter Pandasonic2

    (@pandasonic2)

    You’re great!!! It works perfectly.

    The second question I would have ask to you is: where are stored setting? And you prevented the question and the problem.

    So if insert define( ‘FDP_SKIP_DB_FOR_ARCHIVES’,true ); in wp_config avoid to store data in DB, is it right?

    Thread Starter Pandasonic2

    (@pandasonic2)

    On Monday I’ll go online with the new website and I’ll use your beta plugin. Is exactly what I needed. Do you think to keep this feature in next releases?

    Plugin Author Jose

    (@giuse)

    Hi @pandasonic2

    Thank you! Yes, the filter will be kept for all future releases. The filter appears only if you have more than 30 archives, so it will not disturb users with fewer tags, and it will be useful for situations like yours.

    Thank you for remarking this issue.

    About the database by-pass, this was already possible since some versions, but not officially said. In a future version will be added an option to the backend, but I can’t say when. Also this feature will be surely kept because it solves the biggest problem of FDP, which is the size of the option eos_dp_archives in situations like yours.

    We don’t do it as a default because there are some installations where they use multiple servers for the same website (but not only for the assets) and need the settings taken from the database located in the main server, In those cases taking the settings from the filesystem, would not work. Because FDP is installed on websites with many heavy plugins that require a lot of power, this kind of situation is not so rare. So, we decided to add an option. Until then just keep define( ‘FDP_SKIP_DB_FOR_ARCHIVES’,true ); in wp-config.php.

    Have a great day!

    Jose

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Problems with tags’ is closed to new replies.