Support » Theme: Leaf » Problems with sub-menus on tablet/phones

  • Hi, I’m having some weird issues with the main menu and sub-menus (drop-downs) on tablets/phones (responsive layout).

    On the iPad, I can click the main menu to open the drop-down and select the sub-menus ok, but the main menu link wont work unless I hold my finger down for a few seconds and then select open, or open in new tab.

    On other phones (including Android phones) the sub-menus just done appear at all meaning I can only select the main menu links.

    I’m using a child theme to change colours etc, but have checked just using Leaf theme but still have problems.

    Just wondering if anybody can suggest a way to fix it or if it’s really an iPad/phone problem?

    Thanks in advance,
    David

Viewing 3 replies - 1 through 3 (of 3 total)
  • I’ve just realised from looking at other sites using Leaf that I’m not getting the responsive menu box.

    Scratching head…

    OK, have weird question/problems.

    Just re-downloaded the Leaf theme to make sure I had the latest version.

    If I don’t setup any menus in Appearance > Menus then the Menu (box) appears on smaller screens (responsive).

    But if I select 3 menus Primary, Header Menu (top) and Footer then the Menu (box) doesn’t work.

    Anybody have any suggestions/thoughts?

    Thanks,
    David

    Found the problem.
    I have added a link to a page twice and then changed the name of the first link like this:

    People (links to Staff) (main menu)
    Staff (links to Staff) (sub)
    Classes (links to Classes) (sub)

    Is this a bug or does the responsive Menu not allow links to the same page more than once?

    Regards,
    David

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Problems with sub-menus on tablet/phones’ is closed to new replies.