Support » Fixing WordPress » Problems with site address!

  • Hi All,
    I sent this question to my nearlyfreespeech host:
    “My problem is, when you navigate thru the menu on my site and click on the various links, I need the navigation bar to say http://www.paulaneeley.com/education-and-experience/, instead of paulaneeley.nfshost.com/education-and-experience/. How do I change all the links from the subpages I made on my site from paulaneeley.nfshost.com/etc to paulaneeley.com/etc ?”

    And I got this reply:
    “Take a look in the WordPress dashboard at the settings page. Probably one of these settings isn’t using your own domain:
    WordPress Address (URL)
    Site Address (URL)
    Once you find and fix that (so neither of them uses the paulaneeley.nfshost.com addres, this problem will likely disappear. “

    So I started by changing the Site Address. I then got this error:

    “Warning: is_writable() [function.is-writable]: open_basedir restriction in effect. File(/) is not within the allowed path(s): (/f5/paulaneeley/:/nfsn/apps/php53/lib/php/:/nfsn/apps/php5/lib/php/:/nfsn/apps/php/lib/php/) in /f5/paulaneeley/public/wp-admin/includes/misc.php on line 133

    Warning: Cannot modify header information – headers already sent by (output started at /f5/paulaneeley/public/wp-admin/includes/misc.php:133) in /f5/paulaneeley/public/wp-includes/pluggable.php on line 881″

    I then tried to navigate back to my dashboard and I could not access it! My safari gave me this error:
    “too many redirects occurred trying to open “http://paulaneeley.nfshost.com/wp-admin/”. This might occur if you open a page that is redirected to open another page which is then redirected to open the original page.”

    Any help here???? I really need help!

Viewing 14 replies - 1 through 14 (of 14 total)
  • esmi

    (@esmi)


    Forum Moderator


    Your hosts certainly don’t know anything about WordPress! See Changing_The_Site_URL.

    Hi Esmi,
    Thanks for the reply. I read the article and tried changing the url directly in the database using phpmyadmin. I didn’t know whether to reset both “siteurl” and “home” values to paulaneeley.nfshost.com or paulaneeley.com, so I tried both, and neither worked to access my dashboard again.
    It looks like the only other option I could try (since I can’t access my dashboard) is to ftp to my site and try to find the functions.php file. I looked, however I could not find it.

    Any suggestions?

    Thank you for your help!
    -Paula

    esmi

    (@esmi)


    Forum Moderator


    Set both urls back to paulaneeley.nfshost.com initially.

    I tried that, and I also just tried editing the functions.php file using filezilla and adding this:
    update_option(‘siteurl’,’http://paulaneeley.nfshost.com’);
    update_option(‘home’,’http://paulaneeley.nfshost.com’);

    to the top of the file. Still no luck accessing my dashboard 🙁

    esmi

    (@esmi)


    Forum Moderator


    Well, your site is working just fine. Where did you install WordPress on this domain?

    My whole visible site works totally fine. Except the dashboard which I can’t access. If i try to go to http://paulaneeley.nfshost.com/wp-admin , it gives me an error message.

    I’m not sure where I installed wordpress on my domain. I knew absolutely nothing about websites at the time (and little more now), so the process of installation was a blur :-p
    Where could I look to find out and tell you?

    esmi

    (@esmi)


    Forum Moderator


    Try asking your hosts for assistance with this question. It’s not something that we can determine.

    I did, and they are the ones who screwed me up in the first place by telling me to change my site address 🙁

    Do you know of anyone else I could ask safely to solve this problem for me?

    esmi

    (@esmi)


    Forum Moderator


    You could try hiring someone.

    Hi paulaneeley,

    You forgot to include your reply email address on the jobs.wordpress.net forum.

    Hi paulaneeley

    please send me an e-mail to: info@webcan.ca and I would be fix your problem. you didnt leave any contact info in wordpress job site.

    Thans

    Update,
    I had a friend work on my site. He managed to get by dashboard back up and running, but now the actual pages of the site don’t work! Any suggestions?

    http://www.paulaneeley.nfshost.com
    Click on the menu at the bottom, you will see I get 404 errors.
    Any help would be appreciated!

    -Paula

    oops, sorry all, the address should have been:
    http://paulaneeley.nfshost.com

    Hi Paulaneely,

    You may have a custom menu. The other thing may be that your redirect did not change the menu. Let me know if this helps at all.

    jv8080

Viewing 14 replies - 1 through 14 (of 14 total)
  • The topic ‘Problems with site address!’ is closed to new replies.