Support » How-To and Troubleshooting » Problems with “Settings: Reading” in Admin panel

Problems with “Settings: Reading” in Admin panel

  • Hello,

    I am currently running two entirely different WordPress blogs under two different domain names. Both are version 2.9.2

    Here is the problem. In one of my installations I have options that are missing under the “Settings: Reading” section of the admin control panel. In one installation I am missing the options for “Front Page Displays” … where you can select static content for your homepage etc. … strange indeed.

    Has anyone else encountered this problem? How do I get the options “back” so I can create a static homepage in my blog?

    Please let me know!

    Joshua Neil

Viewing 5 replies - 1 through 5 (of 5 total)
  • Hi,

    Try re-uploading wp-admin and wp-includes from a fresh locally unzipped WordPress fileset through FTP.

    Next, it could be any plugin messing up. Rename the plugins folder through FTP and reload your admin screen and see what happens.


    I am have the same problem and am just wondering where you get a ‘fresh locally unzipped wordpress fileset”? Also if I do this then what happens to for example my images file that is part of include?


    Tab at the top of this page on right hand side “Download”


    Hi Experienceseeker,

    Images in posts or pages are normally uploaded to wp-content/uploads/
    The images in wp-includes are all sort of icons and buttons for WordPress to use.

    I also hit this and I discovered that you don’t get the option to set a static page if you don’t yet have any pages.

    I had deleted the default “about” page and had no pages, hence had no options in settings/reading to set a static page!

    Don’t you feel an idiot sometimes. Don’t know where I am going to find one at this time of night though..

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Problems with “Settings: Reading” in Admin panel’ is closed to new replies.
Skip to toolbar