Support » Fixing WordPress » Problems with REST API and Woocommerce

  • Resolved rafaelmiranda

    (@rafaelmiranda)


    Houdy fellows,
    We have an ecommerce at ekilibreamazonia.com. We use a child theme from storefront, and php 7.

    I´m experiencing a series of problems. Some plugin actualization fails, and the shipping methods have disappeared on woocommerce. Also when i try to write a post i receive an error message “your website have a critical problem”. This has happened after plugins actualizations via ftp. On the health check i have the message “API Rest have encountered a unexpected result, there is a critical error in your website (error 500).

    Does someone knows what could be happening and how can i fix it?

    Does it can be bad server configuration?

    I have a mirror website on mirante.design/sites/ekilibre/ running the same content and it does look ok, no problems there.

    I´ve tried to deactivate all plugins than woocommerce but my shipping methods have not returned.

    Please help. Thanks a lot.
    Regards,
    Rafael

    The page I need help with: [log in to see the link]

Viewing 4 replies - 1 through 4 (of 4 total)
  • Moderator t-p

    (@t-p)

    there is a critical error in your website (error 500).

    Internal server errors are usually described in more detail in the server error log. If you have access to your server error log, generate the error again, note the date and time, then immediately check your server error log for any errors that occurred during that time period. If you don’t have access to your server error log, ask your hosting provider to look for you.

    Meanwhile, try:

    If you have access to your admin panel, try deactivating all plugins. If you don’t have access to your admin panel, try manually resetting your plugins (no Dashboard access required). If that resolves the issue, reactivate each one individually until you find the cause.

    If that does not resolve the issue, try switching to the default theme for your version of WordPress to rule-out a theme-specific issue. If you don’t have access to your admin panel, access your server via SFTP or FTP, or a file manager in your hosting account’s control panel, navigate to /wp-content/themes/ and rename the directory of your currently active theme. This will force the default theme to activate and hopefully rule-out a theme-specific issue.

    If that does not resolve the issue, it’s possible that a .htaccess rule could be the source of the problem. To check for this, access your server via SFTP or FTP, or a file manager in your hosting account’s control panel, and rename the .htaccess file. If you can’t find a .htaccess file, make sure that you have set your SFTP or FTP client to view invisible files.

    Thread Starter rafaelmiranda

    (@rafaelmiranda)

    Hi t-p!
    Thanks for your reply and help. I´ve got the server error log and found many errors. I´ll paste some of them in the end of the message.

    I have access to the dashboard. I´ve desactivated all plugins, and what i found that Woocommerce is causing the problem! I´ve desactivated all of them, have let only Woocommerce, and the error messages appeared, i could not get to the New Post page, and also health check accused REST API problem.

    I also have activated all of them besides Woocommerce and related plugins, and everything goes all right.

    I wonder if there is a method of reinstalling woocommerce clean. I think that maybe i have done a bad installation in the past for this website.

    Thanks

    here is an excerpt of the server error log
    [Mon May 25 08:33:09 2020] [error] [client 189.62.46.134] PHP Fatal error: require_once() [function.require]: Failed opening required ‘__DIR__/admin.php’ (include_path=’.:/usr/share/pear’) in /home/storage/c/ba/cc/ekilibreamazonia1/public_html/wp-admin/index.php on line 10
    [Mon May 25 08:33:33 2020] [error] [client 189.62.46.134] mod_mime_magic: invalid type 0 in mconvert()., referer: https://ekilibreamazonia.com/wp-content/plugins/jetpack/css/jetpack-icons.min.css?ver=8.5
    [Mon May 25 08:33:33 2020] [error] [client 189.62.46.134] mod_mime_magic: invalid type 0 in mconvert()., referer: https://ekilibreamazonia.com/wp-content/plugins/woocommerce/assets/css/dashboard.css?ver=4.1.1
    [Mon May 25 08:34:06 2020] [error] [client 191.252.51.234] ModSecurity: collections_remove_stale: Failed deleting collection (name “ip”, key “44.230.139.63_1759fce451e56b4eb624eea72c06ca78e73f27d0”): Internal error [hostname “ekilibreamazonia.com”] [uri “/wp-cron.php”] [unique_id “XsutLL-8M@oAAGrI@y4AAAAp”]
    [Mon May 25 08:36:21 2020] [error] [client 189.62.46.134] mod_mime_magic: invalid type 0 in mconvert()., referer: https://ekilibreamazonia.com/wp-content/plugins/smart-slider-3/Public/SmartSlider3/Application/Admin/Assets/dist/smartslider-admin.min.css?ver=a1ec7496

    Thread Starter rafaelmiranda

    (@rafaelmiranda)

    Hi, this was because of a bad installation of Woocommerce plugin via ftp. I have deleted it and then reinstalled and this have solved. Thanks.

    Moderator t-p

    (@t-p)

    Glad its sorted 🙂

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Problems with REST API and Woocommerce’ is closed to new replies.