Support » Plugin: NextGEN Gallery - WordPress Gallery Plugin » Problems with qTranslate

  • When using NextGen Gallery and qTranslate together, everything is fine, except when you describe a picture in a gallery with a multilingual description (ex : “<!–:en–>Picture description in English<!–:–><!–:fr–>Description de l’image en Fran├žais<!–:–>”).

    When you go to the page of an album containing this gallery, you see the description in the right language, as the language code (“/fr/” or “/en/”) is correctly added to the URL of the page (or it’s using the default language).
    But when you want to access to the next set of pictures by clicking on the button “2”, “3”, etc…, the description of the pictures come back to the default language of the site, no more to the language currently displayed in the page.
    It’s due to the fact that the link of the buttons “2”, “3”, etc…, doesn’t contain the language code in the URL, unlike the link of the page (it’s “/mysite/page/” instead of “/mypage/en/site” for English).
    Therefore, in the pages 2, 3, … of the album I’m displaying, the descriptions might be in a different language than page 1.

    Moreover, in the page where all the galleries are displayed, the links also don’t include the language code, even if the album page was accessed with that code in the URL

    An example on one of the album pages of my site, explicitly set in English (default language is French) :

    You can see in the links that the language code (“/en/”) is not included in the gallery links.
    By clicking on a gallery and explicitly setting again the language to English, you see the description in English for each picture until you go to page 2 and next ones, where it’s back to French… because the link of button “2”, “3”, … and “>” doesn’t contain the language code.

    So could you check that issue in order to increase the compatibility of NextGen Gallery with the plugin qTranslate, which is essential for multilingual websites?

  • The topic ‘Problems with qTranslate’ is closed to new replies.