Support » Fixing WordPress » Problems with Plugins for Editing Posts/Pages

  • I’m having problems with both WordPress 1.5 and the latest nightly on getting the Text Control plugin ( to work. The plugin shows up just fine in the Plugins and Options panes of the Admin Control Panel, but the “per post” and “per page” drop-down menus that are support to appear when editing just flat DON’T appear. I’ve tried this on completely clean installs of Worpress 1.5 and the 17 Apr 05 nightly, and the problem occurs constantly. I’ve also tried using both Firefox (v1.0.3) and IE6 on WinXP. This happened to me on another plugin as well, but I don’t remember which one that was, since I got frustrated and deleted it.

    I really need the Text Control plugin for my site, so any help is MUCH appreciated!!


Viewing 10 replies - 1 through 10 (of 10 total)
  • PLEASE, anyone, do you have any ideas on this? I’m having the same problem with EzStatic 1.9.2 (the new checkbox for executing PHP code doesn’t appear). A “view source” of the Write Page and Write Posts seems to indicate that the options aren’t being included in these pages when they are being built.

    I can work around this for now, but this is a major pain in the butt…Any ideas out there??


    Moderator James Huff


    Halfelf Minion 🚀

    Have you tried contacting the plugin developers?

    I will be, but since this same symptom occurred across multiple plug-ins, it seems to indicate a WordPress problem in my mind. So I thought I’d try here, first.

    Bumping — is ANYONE having a similar problem, or am I the only one?

    I am having this exact problem. I’ve installed the Text Control plugin in some other (slightly older installs) and it’s worked just great. The Text Control drop down will not appear when writing a new or editing an old entry, at all. I’ve tried modifying the permissions of all the Text Control plugin files to chmod 755. Nothing seems to be working here.

    I’d like to follow up to say that I have another WordPress blog for which I installed Text Control some time ago…it worked fine, but the per post/edit page option area is now gone there too. Again, my brand new install of Text Control on a blog that was installed aprox. 2 weeks ago is not working. I am using Dream Host for both blogs and (sorry to cross-post, I mentioned this on a similar thread), there was a policy change recently and they turned off PHP’s allow_url_fopen.

    Related threads:

    This is a major problem for me, I’ve posted a query at DreamHost’s support forum to see if other WP users there are having similar problems.

    Thank you in advance for any help on this!

    I don’t know if this helps, but if you click SAVE AND CONTINUE EDITING, the text control menu appears below the editing window. Caught me off guard, too.

    I did a clean reinstall based on advice from the author and it worked like a charm when I had the disappearing act problems. Still no answer but it’s worked perfectly since – over a month.

    Save and continue editing is not doing the trick (for me). Text Control is working fine on another (few months older) blog on the same server, so I think that may rule out the PHP policy change.

    I’m kind of freaking out now. Sorry about the repeat posting, I’m really hoping this info could be useful to someone who knows a lot more than I do.

    In addition to not seeing the Text Control options on post or edit pages, I started losing posts if I clicked ‘Edit’ under ‘Manage’. I was doing this a lot to see if I could get the Text Control options to show up after clicking ‘Save and continue’. This happened on two seperate blogs, both with new Text Control plugin installs. After disabling Text Control I haven’t had the problem in either blog.

    [cross-post] Ahah…for those of you who can’t get Text Control to show up on the individual posts (only the config menu shows up in options), I figured out why mine doesn’t work (I think). I host with Dreamhost and I installed my first blog before they had one click installs (so, manually) on a really old domain. Turns out new domains and any time you use a one click install, your domain automatically goes into “Run PHP as CGI” mode. All my new blogs were running in this manner and none of them are able to use Text Control. I just switched my old domain from regular PHP to PHP as CGI and whatddya know? Text Control doesn’t work there anymore. Fortunately Dreamhost allows you to do either with PHP though they strongly reccomend running PHP as CGI.

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘Problems with Plugins for Editing Posts/Pages’ is closed to new replies.