Support » Plugins » Problems with picture in Postie

  • I have a problem. I just upgraded my website to wordpress 2.8, and i also updated my postie to 1.3alpha.
    It is totally ok to post an email without a picture. As soon as i add a picture in my mail the post will not show in the blog. When i goto the admin panel and check for the post then i can see a post with subject tmptitle-and its drafted,- no text or picture in the blogpost.

    Can someone help me?


Viewing 12 replies - 1 through 12 (of 12 total)
  • I found the same problem with attached images. When I run postie manually it inserts the image correctly into the post, but when cron-less postie receives the email, the image does not get inserted in the post content correctly. I do see that the image did get received and assigned to the post’s gallery.

    – Mike M.

    Please try the development version.

    I got the same problem with it.I upgrade it to 1.3beta,but it doesn’t work at all.

    Same problem here, everything works fine (with images) when updating manually via the “Run postie>>” button in postie-setup but when using cron-less or run the get-mail.php on the server I get an empty tmptitle post and it’s drafted.

    Everything works just fine if I skip the images and use text only. I have tried a bunch of different jpeg-encodings but no luck.

    Also when I select any other schedule (I want 10 minutes) it resets back to “hourly” when I press “Update options>>”

    I use gmail and have tried both IMAP and POP3 with the same results.

    I’m running Postie 1.3.3 and WP 2.8.4

    Best regards

    I found the same problem with 1.3.3 and WP 2.8 on Debian. I downgrade it to version 1.3.2 and work fine.

    I downgraded to 1.3.2 and then it works like a charm…

    Except from the double-subject (which I’m sure I’ve seen a solution to somewhere) and [cid:FBDE5BF-5427-4CC66-9C50-3B9672DCC1@MimeCtl] inserted in every post.

    Now I can select cronless “every ten minutes”
    And images works without setting a drafted tmptitle.

    I’m a first timer when it comes to postie so I figured the latest version (1.3.3) would be the one to get.

    i have the same problem. 1 day wasted time trying different things…nothing worked! with wp 2.4.8 and postie 1.3.3
    downloaded postie 1.3.2 and everything worked fine!!!
    with version 1.3.3 it only works, if if start postie manually when i’m logged in as admin in wordpress. if i start it as cron-job (doesn’t matter weather i use lynx or other tec.) it doesn’t work if i use attachments. without attachments it is fine with the newest version. i’ll get a draft post with def. values (tmpTitle, tmpText,..), the output from lynx is like (it seems like parsing stops, when reaching the attachments):

    xxxx@asterix:~> lynx --source
    This is the postie plugin
    Revision: 153324
    Last Changed Date: 2009-09-01 00:28:24 -0400 (Tue, 01 Sep 2009)
    Connecting to (pop3))
    Mission complete, message 1 deleted.
    memory at start of e-mail processing:15716476
    Confirming Access For is authorized to post as the administrator
    adminUser='xxxx'<p>Message Id is :<></p>
    <p>Email has following attachments:</p>primary= multipart, secondary = mixed
    primary= text, secondary = plain
    primary= image, secondary = jpeg

    I just dowloaded the development build (which I can only assume will be 1.3.4) and the problem is fixed!

    I just tested the development build and as mentioned a lot of problems is fixed.
    Now I only get the drafted tmptitle post when sending .3gp movie in an MMS and using the Cronless option (or running get-mail.php) running postie manually via the button works fine.
    Sending MMS with an image and regular email with an image works just fine in cronless now.
    The option to select the update interval still doesn’t stick when you hit “Update now”… it defaults to hourly.

    I have the same issue. I have a cron job running to check mail every 5 min. When the cron job catches the mail, the post comes thru as “tmpTitle”.

    I use Fedora with SELinux on Permissive. It’s been displaying an error message about the location of .tmp files.
    (I assume this makes sense to the developer)

    Checking from withing Postie works fine.

    I have tried the latest release, and the dev release of Postie.



    This is not working for me to, it would be great if this was to work very soon, i can see alot of use for it 🙂

    My error is the same i can see one of the pictures in the media item, but all the text are temp !!! Please Please

    Has this been fixed for 1.3.4 yet? When I send an html formatted email message with an image embedded, it will show a paperclip image in the email however if I send the image as an attachement instead of embedded, it will give me the tmptitle results.

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘Problems with picture in Postie’ is closed to new replies.