Support » Installing WordPress » Problems with permissions and installing updates after installation..??

  • I’ve read some info about this but I just can’t seem to figure out how to ensure I never have this problem.

    I’ve got a local set of WP 3.1 files that I use every single time I install WordPress. Thing is, sometimes after the install I can then install plugins, themes, etc. without entering any FTP credentials and without running into any permissions problems where I’m forced to start chmoding everything to 777 instead of being able to leave them at 755.

    Other times, I cannot. I often run into an issue where after a clean install of WP I go to install some plugins and I have to type in my FTP credentials. Then the plugin will install correctly but when I end up with errors that it couldn’t create the /upload folder correctly, and from there I just keep running into permissions issues and it’s just not smooth.

    I’ve got a Rackspace Cloud Hosting and when I create new accounts there this never seems to happen. Everything runs nice and smooth. I also have a Media Temple dedicated-virtual server. On that one I use Plesk to create new hosting accounts, ftp users, etc. and that’s where I can’t seem to get around all of these issues. I’ve tried using the root account for FTP with the path to the web site I’m working on and I’ve also tried setting up an additional FTP user specifically for the site root. Both seem to give me the same problem.

    Any information on how I can get to the bottom of this and avoid it in the future would be greatly appreciated. Thanks!

Viewing 1 replies (of 1 total)
  • angelleye,

    Make sure all the files in wordpress directory has correct ownership. If you notice different ownership, like apache or nobody, try to chown all files like:

    chown -R user:user /home/user/httpdocs/
    where user is your real username for that account. Then set 755 permissions for folders and 644 for files. You may need to set 777 for /uploads/.

Viewing 1 replies (of 1 total)
  • The topic ‘Problems with permissions and installing updates after installation..??’ is closed to new replies.