Support » Fixing WordPress » Problems with permalinks and sitemap 404

  • jimmy1989

    (@jimmy1989)


    Hello everyone,

    I have been working on this WordPress site since recently and found out two main problems which may be likely to prevent me from being able to add the site to Google Console and other webmaster tools, where I know actually what to do (I am more of a SEO
    person and not a dev).

    First, I noticed the website couldn’t be referenced on either Google Search console, Yandex Webmaster tools. When I try to do it I get with Google Search console
    Verification failed for https://belrusiontranslation.com/ using the Meta tag method (15 minutes ago). We couldn't find the verification meta tag.

    and with Yandex

    Rights haven't been verified
    We couldn't load the page because response code isn't 200. May be server's settings are incorrect. 
    
    HTTP status code	406 Not Acceptable
    
    <!DOCTYPE HTML PUBLIC "-//IETF//DTD HTML 2.0//EN">
    <html>
      <head>
        <title>
          406 Not Acceptable
        </title>
      </head>
      <body>
        <h1>
          Not Acceptable
        </h1>
        <p>
          An appropriate representation of the requested resource / could not be found on this server.
        </p>
      </body>
    </html>

    I must add that I have used the Head, Footer and Post Injections plugin to add the meta verifying for both, but when I do verify on the webmaster tools, they don’t appear.

    I also tried many times for Webmaster tools with Yoast, to activate and turn off the Yoast SEO tool. To add the content from meta of both Yandex and Google and it never actually worked either when verifying from Google Search console and Yandex Webmaster.

    Second, there is also the problem with the sitemap, with both Yoast SEO and Google XML Sitemap, I get the 404 error (of course I disabled Yoast Sitemap when using the Google XML sitemap)
    I get a 404 Error with both plugins. I don’t have the W3C Cache plugin installed (as far as I know, it doesn’t appear in plugins list) as apparently it’s a source of issues.

    How could I solve this in my situation?

    Finally, I also get (I can’t see the beginning of the error in the admin panel) this error for permalinks in the top of the WP window above options to change in the permalinks page.

    _basedir restriction in effect. File(/) is not within the allowed path(s): (/home/httpd/vhosts/soxes-projects.ch/:/tmp/) in /home/httpd/vhosts/soxes-projects.ch/hp.soxes-projects.ch/wp-admin/options-permalink.php on line 88 Warning: is_writable(): open_basedir restriction in effect. File(/) is not within the allowed path(s): (/home/httpd/vhosts/soxes-projects.ch/:/tmp/) in /home/httpd/vhosts/soxes-projects.ch/hp.soxes-projects.ch/wp-admin/includes/misc.php on line 220

    I also notice this at the bottom of the permalinks page

    ” If your .htaccess file was writable, we could do this automatically, but it isn’t so these are the mod_rewrite rules you should have in your .htaccess file. Click in the field and press CTRL + a to select all.

    Then these lines of code

    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>

    How can I modify it? Should I? Or even, could I? Because the site (WP panel address) also have a hosting different from WordPress.

    I’m sorry if I mixed up one error with another, because I’ve been on it for hours and it doesn’t seem to work, and some changes in tutorials/support threads I’m not sure if they are to be done in my case.

    The page I need help with: [log in to see the link]

Viewing 4 replies - 1 through 4 (of 4 total)
  • JNashHawkins

    (@jnashhawkins)

    Okay, your website is hosted at something called sui-inter.net but all I saw was a blank page there. You are running a self-hosted WordPress on a Linux host running Plesk as a control panel.

    Your site is on a Blacklist also…

    https://sitecheck.sucuri.net/results/https/belrusiontranslation.com

    All your links are broken that I could see. That email link needs to be a mailto: instead of http: or https:

    Try swapping your permalinks to plain, save that, and then to whatever you wish… I always choose “day and name” unless I really need something else. Save again!

    Dashboard –> Settings –> Permalinks

    Let us know if you need more and your web host might be a good source of help also…

    JNashHawkins

    (@jnashhawkins)

    I also looked for your sitemap but couldn’t find it…

    Since WordPress can’t write the htaccess for you, my best guess is you don’t have permissions set properly in your directories. That would keep WordPress and either of the sitemappers from writing their files.

    You probably can add those via FTP if needed but your host might be able to help fix the whole problem or you might try this…

    https://wordpress.org/support/article/changing-file-permissions/

    This article can help you with the other issue in my other answer also if needed. I’m hoping that fixing the links and requesting the block be removed will settle everything though.

    https://wordpress.org/support/article/hardening-wordpress/

    autotutorial

    (@autotutorial)

    https://support.google.com/webmasters/answer/35179
    Yoast Seo set google search console for you, if you have used google Analytics you can set google search console from there. https://yoast.com/wordpress/plugins/seo/add-website-google-search-console/
    Yoast Seo add your sitemap if you enable it.

    Google search console for analytics https://support.google.com/analytics/answer/1308621
    Plugin for Analytics https://wordpress.org/plugins/google-analytics-for-wordpress/

    Note* I checked your api rest and it works with the rewriting of the url (mod_rewrite) requirement to create a proper sitemap with Yoast Seo.
    Please you can create test.php?

    <?php
    echo __FILE__;

    Set your document root into wp-config.php, first of require_once (copy output of your scrip without /test.php)

    $_SERVER['DOCUMENT_ROOT'] = 'output script';
    $_ENV['DOCUMENT_ROOT'] = 'output script';
    jimmy1989

    (@jimmy1989)

    Thank you first for your replies.

    I am rather surprised and a bit shocked by the site blacklisting. I need to request from McAfee to solve it now or you think when the host issues will be solved?

    Also by the fact the host is “unknown” in your link (about blacklist) and on the other hand you fond out (I also found the DNS on a whois checking website) it’s sui-inter.net and I thought it was hosted on soxes-projects.ch, which is linked to soxes.ch, which unfortunately (for me) is only-German speaking website.

    Contacting the host, well I will try to, I only found out some contact info (a mail) from this sui-inter.net on this, but not sure if they are correct. I didn’t register the website and from what I knew it is linked to a German-only (Swiss) website (soxes.ch), not to a site that shows blank like this sui-inter.net .
    https://threatintelligenceplatform.com/report/sui-inter.net/3rBSvW5RWN
    Don’t know if soxes.ch and sui-inter.net are linked, I suppose I will find out when I contact them…

    I’ll try to find more on the issues and follow these articles by tomorrow (it’s over 11pm/23:00 here).

Viewing 4 replies - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.