Support » Plugins and Hacks » [Resolved] Problems with permalinks after upgrade

[Resolved] Problems with permalinks after upgrade

  • Hi
    I’ve just upgraded to the latest version of NextGen Gallery and now my galleries do not show. I’m getting a Page Not Found error. If I uncheck the Deactivate gallery page link in the Gallery settings, clicking on the links to the galleries simply refreshes the gallery page without showing the requested gallery. If I uncheck the Activate Permalinks option in the General Options, then the galleries show but without a title or anything.

    I have tried clicking the Save button to update the Permalinks, which I gather is the way to do this, but it has no effect and everything remains the same.

    Also, the styling of my gallery page seems to have been lost.

    Any help greatly appreciated.

Viewing 15 replies - 31 through 45 (of 74 total)
  • No problem! Thanks!

    This is happening to me, too. I look forward to some advice!

    Hey guys, i’m having the same problem…

    Take a look at this:

    Also…Alex, how can we downgrade if the newest version updated the database? I’m afraid to try that.

    check the permalink structure : /%category%/%postname%/ but it works for me fine, so no idea where to look & start… if someone has a test blog where I can debug it more in-depth, please contact me by mail.

    If someone would like to downgrade, delete the plugin folder and load an older version from here :


    Not sure what your email address is 🙂

    See my about page…

    By using your permalink structure: /%category%/%postname%/ all is working as it should. Shows properly now.

    It would be nice, for me however, if I would be able to just use the permalink structure of just /%postname%/. Any ideas on this? It must be something in how you’ve coded the permalink structure for nextgen??

    Similar problem here.

    I wanted to use tagcloud, but with my /%postname%/ permalink structure it doesn’t work well.

    My setup was:
    1. permalink structure /%postname%/
    2. image browser enabled
    3. tagcloud used on a page (not a post)

    Result: 404 errors – Page Not Found

    When I changed the permalink structure to any different (one of the default ones, or /%category%/%postname%/ or even /post/%postname%/, the tag cloud started to work (partially): clicking on a tag from the cloud redirected to a dynamically generated gallery of pictures marked with this tag, but then clicking on a thumbnail didn’t show the image browser (new page opened but with no image browser).

    So I changed it to:

    1. permalinks disabled (default links structure, you know, the one with question marks)
    2. image browser enabled
    3. tagcloud used on a page (not a post)

    Now everything worked like charm – tag cloud worked, clicking on a tag redirected to a gallery of tagged pictures, and clicking on a thumbnail opened a working image browser.

    And tried another version:

    1. permalinks enabled (set to /post/%postname%/)
    2. image browser disabled (shutter effect chosen)
    3. tagcloud used on a page (not a post)

    Now things work fine again – pictures open properly in the shutter.

    But when I changed it to image browser – it was wrong again…

    I think it must be easy to replicate, because it doesn’t seem to be a plugin conflict but some kind of a problem with permalinks, tags and image browser…

    I had worst problems with /%postname%/ type permalinks, and with permalinks disabled things work best.


    I’ve also noticed a problem with pagination-permalinks-404error problem after upgrade (1.7 worked fine with the same conf.) Now i’ve turned off pagination (i’ve made upgrade on working site 😉 and it looks fine, but we know it is not.


    The second problem after upgrade that i’ve noticed is
    option->General Options->activate permalinks -> Gallery Slug name – no matter what you put there – it ich changed to “nggallery”

    No idea what to do, i hope there will be quick bug fixing path or upgrade 😉

    I can confirm it.

    I had to disable pagination, because it was giving me 404 error on pages other than the first one.

    Also no matter what slug I define, it always remains “nggallery”

    No way i’m changing my permalink structure. That would be an SEO nightmare.

    I advise that other wordpress users don’t do that either. Just wait for alex to fix things.

    I updated and got the ‘not found’ error. Then I went into my FTP to downgrade to the 1.7.4 and now the same ‘not found’ error is coming up. Please help!

    My website is http://www.studiomme.com. It’s the illustration page that is down.


    Resolution for now: turn off pagination and … wait 😉 we all hope that Alex will work on that. So, we should consider a donation issue 😉

    Also for me after the upgrade is impossible to view the galleries.

    What can I do to solve it ? When I see the URL on hover the album I see the correct URL but when I click it always redirect me to the Album Page.

Viewing 15 replies - 31 through 45 (of 74 total)
  • The topic ‘[Resolved] Problems with permalinks after upgrade’ is closed to new replies.