Support » Fixing WordPress » Problems with pages (quite urgent..)

  • rbresjer


    I while ago, I installed WordPress to my server and customized it to my taste. Because I am going to use the weblog as my travel diary, I haven’t used it a lot yet.

    Tomorrow my journey starts so today I wanted to test my WordPress weblog once more. I have posted a new blog post which worked just perfectly. WordPress wanted me to upgrade to 2.8.4 (was 2.8.2 I guess) so I did (automatically. Worked also like a charm.

    Now I discovered two problems:
    – I use the WPG2 plugin to connect my Gallery2 to WordPress. WPG2 creates a dummy page (under Pages) which is used to redirect the requests to the plugin I guess. Now out of a sudden another page also includes the Gallery2 and my original text isn’t showing up. When I edit the page in the administration panel, my text shows up. However, when I want to Publish..
    – I can’t publish pages anymore. Publishing a blog post works just fine but when I want to publish a page, my browser is keeps loading but doesn’t show anything. At the same time, my server load gets extremely high (60.00+) because Apache2 spawns about 10 processes which all produce maximum CPU load, and MySQL also shows up in the top CPU time consuming processes. The only solution is to shut down Apache, wait until all child processes are killed and restart Apache.

    I tried downgrading to WordPress 2.8.2 but that didn’t help one bit. Also I have updated my server with the latest version of Apache but that also didn’t work out.

    It seems like something is messed up somewhere (maybe caused by WPG2? But it did work well before..) but I don’t know where to look. And I’m leaving on my trip tomorrow..

    Versions of server software I use:
    OS: Ubuntu 8.04 hardy
    Apache: 2.2.8-1
    MySQL: 5.0.51a
    PHP: 5.2.4-2

    Thank you very much in advance!!


Viewing 2 replies - 1 through 2 (of 2 total)
  • WebTechGlobal


    I suspect the cron is causing a permanent process shutdown on my own blog and it sounds like it could be happening to you, maybe.

    I have a lot of WordPress blogs and I only upgrade one of them to be safe.

    The one that I upgraded to the latest 2.8.4 is which you may see is currently down with 403 forbidden message. It has been down pretty much since upgrade.

    I must stress I cannot be totally sure that my situation is similiar however my hosting emailed me to say it was probably a problem with a plugin because “wp-cron.php” was in the error. So that file is defo being triggered for some reason and was not prior to this upgrade because I never had this issue and made no changes other than upgrading.

    The question now is, does disabling given plugins resolve the issue…

    If it does (and you won’t know without testing) then you don’t have much choice other then disabling said plugin(s).

    You left it a bit late to be testing, but i’d say your best shot at having a workable blog in time is to either..

    a) disable plugins that cause a problem (If that’s the case).
    b) employ a developer to look at the problem so it can be resolved before you leave (you’d need to stipulate this with the person doing the work, if you can get hold of someone to do it today).

    I have to be honest, i very much doubt you’ll get enough in-depth help in the space of a day to be able to totally isolate the problem if it’s not a plugin specific issue, quite frankly you’ve left it too late.

    As a side note, i’ve not experienced any such issues with any of the 2.8 versions.

    From the sounds of what you described it seems like something is going into an iffinite loop (that can happen in PHP, when something doesn’t get the results it should do) and as a result it keeps executing until the server runs out of resources.

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Problems with pages (quite urgent..)’ is closed to new replies.