• Resolved tmphoto2

    (@tmphoto2)


    Hi,

    I recently made some minor changes to my website http://www.tommanleyphotography.com and encountered some problems when updating AIOSEO plugin to version 4.0.12. After updating some features of website (blog sliders) were not working as usual and I received notification ‘AIOSEO has detected static sitemap files in the root folder of your WordPress installation. As long as these files are present, AIOSEO is not able to dynamically generate your sitemap’
    When I deactivated plugin site appeared ok. At this point I contacted my website host who suggested it may be an issue with plugin and rolled the AIOSEO back to version 3.5.2. ( in the plugin section of dashboard it is now listed as version 999.3.5.2) All seemed to be ok but I have now realised that descriptions and titles of pages are not appearing as entered into All in One SEO settings. I have used the AIOSEO pack when making new posts and pages for many years and have been happy with the visibility and descriptions of posts in search engines. Not sure why it appears that there is a problem with this and any help appreciated. I am not a web developer but rely on good SEO for my business profile.

    • This topic was modified 7 months, 1 week ago by tmphoto2.
    • This topic was modified 7 months, 1 week ago by tmphoto2.
Viewing 7 replies - 1 through 7 (of 7 total)
  • Change seo plugin , this plugin is just about making money now, no regard for customer seo. Roll back to 3.7 . Wait and hope it works again or switch to better seo plug in. Staff here will just palm you off.

    Plugin Support wpsmort

    (@wpsmort)

    @tmphoto2 Can you please provide more detail as to what you mean by “descriptions and titles of pages are not appearing as entered into All in One SEO settings”.

    Are you comparing what’s in the source code of your posts / pages to what you’ve entered in AIOSEO? If not, then that’s what you should check. View the source code of one of your posts or pages and see if the <title> tag and the meta description matches what you set in AIOSEO.

    If they are different, try clearing all caching, switch to the default Twenty TwentyOne theme and deactivate all other plugins and then see if they match.

    Thread Starter tmphoto2

    (@tmphoto2)

    Ok thanks.. i have had a quick look ( first time I’ve checked source code ) and title and description tags seem to match what i set in AIOSEO. But these do not seem to be appearing in search results.

    Plugin Support wpsmort

    (@wpsmort)

    @tmphoto2 Google doesn’t have to use your SEO title and description. Please see their article on this here – https://developers.google.com/search/docs/advanced/appearance/good-titles-snippets?hl=en&visit_id=637490162290576088-2481677828&rd=1

    As long as what’s in the source code matches what you set then AIOSEO is working correctly.

    Thread Starter tmphoto2

    (@tmphoto2)

    The title towards the top of Source Code generally matches but the meta description does not match and is the same generic text on all pages and posts. Under the AIOSEO pack source code there is another meta description which matches what i entered although this does not seem to come up in search engines – i only seem to get the generic site description come up. Im sure before my host rolled back to version 3.5.2 the descriptions which came up in search engine results were much better. Im not sure if the plugin is doing much at all now, however i do not want to mess about with it too much.

    Plugin Support wpsmort

    (@wpsmort)

    @tmphoto2 That generic meta description is coming from another plugin or your theme so you’ll want to find it and remove it. It’s probably in your theme.

    Thread Starter tmphoto2

    (@tmphoto2)

    thanks – in the end a friend took a look at the themes code and there was a line that was putting the sites tagline in the header area so there was a double description, removed it now and hope things are ok.

    • This reply was modified 7 months, 1 week ago by tmphoto2.
Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Problems with page titles and descriptions’ is closed to new replies.