Support » Plugins and Hacks » [Resolved] Problems with multi content blocks after Update

[Resolved] Problems with multi content blocks after Update

  • Hi,

    i have updatet wordpress to 3.5 and multi content blocks to 3.0.1 at the same time. I have many content blocks in twelve templates. Now i have a problem. If i try to create a new conten page with a template i get this message: “Your server doesn’t allow remote HTTP requests using wp_remote_get. You will have to visit this page manually to update which blocks are used on each page.”
    If i try to edit exiting pages with multi content blocks the editor windows of every content blog is change into specified fields with names like “mcb-xxx”. I can see the editor windows of every content block after reload but i cant edit the content.

    Any idea??


Viewing 15 replies - 1 through 15 (of 27 total)
  • Plugin Author Trendwerk


    So if I understand correctly you do see the content blocks, but you can’t edit the content. Why can’t you edit it? Does it not save correctly, or are you just not able to type in the content area?


    thanks 4 ur fast answer. My english is not the best – sorry.
    1. I can type into the content area but it doesnt save it.
    2. when i try to update the page content in the dashboard the editing windows are not available after saving.
    3. I see the exiting content blocks in the frontend.

    Plugin Author Trendwerk


    That’s quite strange. I cannot seem to re-create this error myself. Does it work correcly when you comment (// in front of the line) line 69 from assets/inc/functions.template-tags.php?

    Yeaa – It seems that it works. Many many thanks!

    If i get more or other probs i´ll post it.

    Plugin Author Trendwerk


    Ok, thanks. We still don’t really know what the real problem behind this is, so we can’t fix it right now. Hopefully we’ll be able to re-create the bug.

    Im sure u will find it! Its a great plugin!

    I have the same problem. I’ve used the plugin successfully in the past, but the admin panel is not updating (not showing the extra wysiwyg modules).

    Commenting out (and even deleting) line 69 in above mentioned file did not do the trick, unfortunately. Any other suggestions?

    BTW, I’m using a theme called “Peacemaker” bought on Themeforest, if that has known to be cause of these issues.

    Plugin Author Trendwerk


    I don’t know about that theme and if it could cause any problems. Do you see the blocks at all? Or do you see them and they’re gone after updating?

    Could you try commenting out line 89 and 90 of assets/inc/class.MCB.php? Then you should first visit the page in the front-end and try again in the back-end.

    Let me know if that helps.

    Thank you for your reply.

    Late last night, I deactivated my theme, reactivated it. I also deleted the MCB plugin and re-installed it, commented out line 69, and wrapped the “get_block” line in style="display:none" and it started working after one time displaying the HTTP request error. Now it works. However – Now i have to figure out why it displays on ALL templates.

    I will try to comment out line 89 & 90 like you suggested to see if that irons out any inconsistencies.

    That being said, i really like the functionality of the plugin. Why it’s not part of core WP as an option, is beyond me. All the sites I’ve done on behalf of clients employ it. So, thank you!

    Plugin Author Trendwerk


    Thanks for your help and compliments. We’ll continue to work on it, the plugin has recently been rewritten completely because it was doomed to break some day.

    Now it’s prepared for the future and we’ll keep working on it. Hope we’ll fix this issue soon!

    It still gives me same trouble, after each save in backend, multiple block becomes blank and doesn’t show.

    After i save it again, it comes back but MBC block remains blank.

    Plz suggest solution.

    Plugin Author Trendwerk


    Did you try commenting out lines 89 & 90 of ‘assets/inc/class.MCB.php’ the plugin?

    When i do that, it throws plugin error……

    Plugin Author Trendwerk


    Woops, the line numbers changed in the last update. In case you have the latest version (3.0.3), the lines to comment are 101 and 102.

    We’re working on this, but I still haven’t found a way to re-create this bug. So it’s quite hard to see what’s causing it. So in future updates, it might not be fixed and you may have to re-comment these lines.

    Try comments these lines and visit the page in the front-end. You will probably see the editor now. Let me know please!

    Yeah it did fix…. Will it be permanent solution? I kept loosing content every nw and then before this fix…

Viewing 15 replies - 1 through 15 (of 27 total)
  • The topic ‘[Resolved] Problems with multi content blocks after Update’ is closed to new replies.