Support » Plugin: RVM - Responsive Vector Maps » Problems with markers

Viewing 11 replies - 1 through 11 (of 11 total)
  • Plugin Author Enrico Urbinati

    (@enrico-urbinati)

    Hi mate,

    I’ve checked and I do not see any issues with last release on markers.
    Can you please provide me a link to check eventual issues?
    Any error on WP end ?
    Which php version are you using?

    Thanks

    Hey, I am using PHP 7.3.5, the page is actually not public, but I can create you a login, if you want to have!

    Plugin Author Enrico Urbinati

    (@enrico-urbinati)

    Sure, it’s fine for me.

    Oh shit, I am so sorry, I found the problem. For any reasons the markers I had have are gone. After recreating theme, everything works fine.

    Plugin Author Enrico Urbinati

    (@enrico-urbinati)

    Ok ok, no worries, glad you was able to fix it!
    Whenever 🙂
    Have a nice day,
    Enrico

    Hey again, I know have to say, that for any reason the markers disappear. I yesterday created all markers new, and exported them for backup. This morning, they all where gone, I than just reupload the export. But why is is this happening? Are the stored as transitions in the database and get maybe deleted?

    Plugin Author Enrico Urbinati

    (@enrico-urbinati)

    Ehi!

    How many markers you’re trying to save?
    I’m asking because by default php save 1000 record at a time.

    Considering the fact that main settings, subdivisions and markers fields are sent as a whole, probably you reached this quota !

    I tried this plugin

    which basically alerts you when this limit is reached.

    Here an explanation on how to solve it via php.ini or via htaccess file.

    Newer versions of PHP implement a php.ini directive called max_input_vars usually set to 1000. This means that posting > 1000 form fields for instance would be truncated preventing data from being saved.

    This can be changed in php.ini:

    max_input_vars = 2000

    If you need to do this via htaccess (on a shared host for instance) you may use:

    php_value max_input_vars 2000

    This is the page where I’ve got the workaround above : http://docs.woothemes.com/document/problems-with-large-amounts-of-data-not-saving-variations-rates-etc/ ).

    Please let me know if you are able to solve it.

    Hey, max_input_vars is set to 4096, but the markers are disappear from the settings page. The get deleted. Today, after importing the marker file, they don’t get shown on the frontend… complicated thing!

    Plugin Author Enrico Urbinati

    (@enrico-urbinati)

    Uhmm… weird, never heard about such an issue…
    How many markers are you trying to save?
    Have you checked using the plugin I’ve suggested to count how many records are saved at one time?

    Consider that each marker bring at least 3 fields to be saved into db.
    Furthermore, do you see any issues in console on the front end and/or in dashboard?

    Thank you.

    I have no done a trouble shoot by reinstalling the whole map system. It looks like the maps markers and maps always disappear on cleaning the redis cache. So the my question is: How are they stored?

Viewing 11 replies - 1 through 11 (of 11 total)
  • You must be logged in to reply to this topic.