Support » How-To and Troubleshooting » [Resolved] Problems with “<” via XMLRPC (Posting from Iphone)

[Resolved] Problems with “<” via XMLRPC (Posting from Iphone)

  • I’ve been using the WordPress for Iphone app for a while and it has been working really great!
    However when I try to upload photos now I can se that all opening tags “<” are stripped out of the post.
    Even when I just try to write a post containing that specific char it’s just missing.
    Very annoying.

    Any clues?
    I have disable alot of plugins, switched themes but still the same behaviour…

Viewing 9 replies - 1 through 9 (of 9 total)
  • I’ve tried using a different Iphone with just to rule out that my latest upgrade of the phone was the problem.

    A week ago i did a yum update on my server (Running Fedora), can any fedora package cause this behaviour?

    Anyone else running on theese packages?

    libxml2-devel – 2.7.1-1.fc8.i386
    wbxml2 – 0.9.2-13.fc8.i386
    libxml2-python – 2.7.1-1.fc8.i386
    libxml2 – 2.7.1-1.fc8.i386

    Downgraded to libxml2-2.6.27 and after that everything works well again, guess there is a bug somewhere…

    Could someone please offer me some help on how to downgrade to libxml2-2.6.27? I’m very new to wordpress and self-hosting. I have access to my server through CyberDuck and through a web admin page. Will I need to delete a file and replace it with an older version?

    I have a couple of lines on how I solved it in my blog:


    You have to run the command as a priviliged user ie. root

    Thanks to every-one who has identified where this problem lies — i have been experiencing it for some time which hasn’t been helpful when my blog is entirely picture based!

    @thomaz — thank you for your solution but i am not familiar with libxml or how i might downgrade it – is this something I can do myself or is it server side and I will need to get in contact with my hosts?

    Like 123jmail i have access to my server files through ftp but anything more than that might be beyond me.

    If anyone can explain method in slightly more laymans terms i’d be incredibly grateful

    olay: No if you are running on a “webhotel” you need to contact them as it’s serverside…

    Some Host unable to downgrade libxml2 older version.

    This may helpful

    see the workaround solution for this wordpress Problems with “<” via XMLRPC

    I’ll contact my webhost to update the library but this plugin works:
    (the manual fix to comment out didn’t work for me)

    mackaaij: I tried your plugin and while it forms the HTML properly I’m still having trouble. When I upload an image it creates the file on my server but does not actually save the photo correctly. More here.

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘[Resolved] Problems with “<” via XMLRPC (Posting from Iphone)’ is closed to new replies.