WordPress.org

Forums

[resolved] Problems with Kimili (10 posts)

  1. billhance
    Member
    Posted 8 years ago #

    I am having trouble using the Kimili plugin. I suspect the problem is some setting on my server but I am not sure. I have setup the plugin correctly and if you view the source code on the page, you will see that the required script is there, but there is nothing viewable on the page.

    Here is the link:
    http://www.grottoplumbing.com/?page_id=5

    Oddly enough it works if you enter this following bit of code before the kimili tags:
    <script src="http://www.grottoplumbing.com/wp-content/plugins/kml_flashembed.php?flashobject.js" type="text/javascript"></script>

    If I check in IE I get the error:
    'FlashObject' is undefined

    Any help would be greatly appreciated. Thanks.

    Below is some information that may or may not be useful:
    Wordpress Version: 2.0.3
    Kimili Version: 1.1
    PHP Version 4.4.1
    Browsers Tested: Firefox 1.5.0.4, IE 6+

  2. billhance
    Member
    Posted 8 years ago #

    anybody?

  3. yosemite
    Member
    Posted 8 years ago #

    Never heard of Kimili. Perhaps you could supply a link?

  4. billhance
    Member
    Posted 8 years ago #

    Sorry should have been more specific.

    http://www.kimili.com/plugins/kml_flashembed/wp

    Kimili is a plugin that allows you to use flash on your posts and/or pages. It's basically a plugin that utilizes the SWFobject (formerly FlashObject).

    http://blog.deconcept.com/swfobject/

    Thanks.

  5. jwurster
    Member
    Posted 8 years ago #

    I've had conflicts with other plugins. However, when I have gotten it to work, the code looks like (version 0.3.1):
    <kml_flashembed movie="http://localhost/wordpress/wp-content/plugins/myriad.swf" height="250" width="400"></kml_flashembed>

  6. billhance
    Member
    Posted 8 years ago #

    The required tags have changed a little with versions but even when I try the old tag it doesn't seem to be showing on the page. I think that it is processing the required markup but it's not recognizing the function call (either because it can't find the file, or there is something prohibiting it from viewing the file). Though I could be a 100% wrong.

  7. jwurster
    Member
    Posted 8 years ago #

    I just updated to the version 1.1 and changed the coding in my page and it worked. What other plugins are you using and what version of wp are you using?

    How is the video working on your main page?

  8. billhance
    Member
    Posted 8 years ago #

    I am using wordpress version 2.0.3. The other plugins I have activated are:

    "Static Front Page" http://www.semiologic.com/software/static-front/

    "Search Pages"
    http://randomfrequency.net/wordpress/search-pages/

    "Flash Quicktag"(was disabled during testing)
    http://www.ssdesigninteractive.com/ssdesign/?p=82

    On the main page I am using the "satay method" for displaying flash in conjunction with the flash quicktag plugin. It's working fine using that version but I am just curious as to why I can't get the kimili to work, for it will be easier to instruct my client how to update or change it when the project is complete.

  9. billhance
    Member
    Posted 8 years ago #

    Anybody think it could be a php setting or something?

  10. billhance
    Member
    Posted 8 years ago #

    Pretty simple oversight. I forgot to put the wp_head in the head of my template.
    '<?php wp_head(); ?>'

Topic Closed

This topic has been closed to new replies.

About this Topic