WordPress.org

Ready to get started?Download WordPress

Forums

Ajax Event Calendar
Problems with IE and WP 3.6 (19 posts)

  1. Martin.Gutsch
    Member
    Posted 1 year ago #

    I cannot add new events and I cannot view all the event details with IE. It was possible before the update to WP 3.6
    But it seems to work with other browsers. But the main browser is IE.

    http://wordpress.org/plugins/ajax-event-calendar/

  2. jlihle483
    Member
    Posted 1 year ago #

    I have the same problem. Works fine in Firefox. Have been playing around with IE settings but haven't found the correct one. Any hints would be appreciated. Thanks

  3. william_kowalski
    Member
    Posted 1 year ago #

    A client of mine is having the same problem and this is a major downer. Can we get a fix to this ASAP please? This is a busy workplace and their calendar being down is not a good thing.

  4. Hirschan
    Member
    Posted 1 year ago #

    It seems that the calendar stopped working with Windows and Explorer. I have asked users to email me and most of them report that Windows with Chrome, Firefox and other browsers, as usual, seems to work, but not if they are using Explorer. You wonder why no one can put down Explorer for good.
    Of course it's great if Eran can find a fix for this problem as soon as possible.

  5. justinrogers
    Member
    Posted 1 year ago #

    I am getting this error message in IE9 when clicking on an event on the calendar -- the event overlay with details doesn't appear in IE but it works in other browsers.

    SCRIPT438: Object doesn't support property or method 'removeExpression' -- jquery.simplemodal.1.4.3.min.js, line 16 character 133

  6. jlihle483
    Member
    Posted 1 year ago #

    I Googled the above error and came up with this:
    http://stackoverflow.com/questions/12046242/simple-modal-jquery-1-8-0-and-ie9
    I'm not an experienced programmer so I don't know if this is even the same problem (sounds like it) but thought I'd put it out there.
    As for people putting down IE - I concur (and have) BUT I'm using the calendar on a church website and 80% of the congregation use IE because that's what came with the computer and they're afraid downloading and installing Firefox will blow it up or something. Sigh!

  7. Ben Kaeding
    Member
    Posted 1 year ago #

    I had to use a modified version of the SimpleModal js file to correct the IE issues as well. You can download it here from my site: http://www.benkaeding.com/jquery.simplemodal.js

  8. jlihle483
    Member
    Posted 1 year ago #

    Got it - thanks. Where to I put it?

  9. Ben Kaeding
    Member
    Posted 1 year ago #

    check out my latest post over here: http://wordpress.org/support/topic/event-calender-2?replies=15

    I hope it helps.

  10. Kimber254
    Member
    Posted 1 year ago #

    Hi, What is a SimpleModal js file and where do I ftp it into?

    Thanks

  11. bryomedia
    Member
    Posted 1 year ago #

    @Kimber254, FTP to your wordpress installation, and go to wp-content/plugins/ajax-event-calendar/js/jquery.simplemodal.1.4.3.min.js.

    Open that file, change its contents to the ones from http://www.benkaeding.com/jquery.simplemodal.js, save it, and then ftp it over to the live site in the same folder/file location.

    There are other ways of doing this, but this is how I fixed mine.

  12. ggl
    Member
    Posted 1 year ago #

    @bryomedia, I tried a lot of proposed solutions in this forum to get the plugin working in IE and finally, yours works!!

    Thank you.

  13. Walter_
    Member
    Posted 1 year ago #

    I appreciate the suggestions, but the jquery.simplemodal.1.4.4.min.js "fix" is not working for me. The Ajax Event Calender was perfect for our purposes (even sent Mr. Miller some money), but I need to start considering alternatives. Does anyone know a similar calendar plugin that I can use?

  14. jamiewalden
    Member
    Posted 1 year ago #

    @walter_ did you clear your cache and restart IE after installing the .js? And if you're using any caching plugins, you might want to clear them as well. Ben's fix worked for me. (Thanks, Ben)

  15. mybowls
    Member
    Posted 1 year ago #

    If you dont want to mess with code and wait for an update you can instruct users using crappy i.e to....
    Turn compatibility view on under tools in the browser

  16. peiguy
    Member
    Posted 1 year ago #

    Updating jquery.simplemodal.js worked for me. Thank you

  17. davco
    Member
    Posted 1 year ago #

    Is the developer planning on resolving this issue?

    If not can he/she tell us so we can look for an alternative solution.

    This is a SUPERB plug-in currently spoiled by not being compatible with IE.

    We all know IE is a piece of cr*p, but it is still being used by many.

  18. davco
    Member
    Posted 1 year ago #

    We now have confirmation that the developer is no longer updating this plugin or supporting it.

    http://code.google.com/p/wp-aec/

  19. kaytlyn
    Member
    Posted 1 year ago #

    Sad that the developer can no longer support it, but good to know. The above fix worked for me when I upgraded to 3.7 today.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic